Add an option to restore all previous tabs on browser restart

VERIFIED DUPLICATE of bug 159357

Status

()

Firefox
Tabbed Browser
--
enhancement
VERIFIED DUPLICATE of bug 159357
13 years ago
13 years ago

People

(Reporter: Paton Lewis, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; en) Opera 8.0
Build Identifier: Mozilla/5.0

Please add an option that allows the browser to remember what tabs you last had 
open and which re-opens them automatically when you restart the browser.

Reproducible: Always

Steps to Reproduce:
1. Open multiple tabs.
2. Restart the browser.

Actual Results:  
The previously opened tabs are gone, and there is no option to allow me to 
change that behavior.

Expected Results:  
Provide an option that causes the browser during start-up to automatically re-
open all tabs that were previously opened when the browser was last closed.

Opera has this capability and this is the only feature that keeps me using Opera 
instead of Mozilla or Firefox. I suspect that this feature could help increase 
Mozilla and Firefox market share.

Comment 1

13 years ago

*** This bug has been marked as a duplicate of 152391 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 2

13 years ago
This is not a duplicate of 152391. Bug 152391 is an enhancement request for 
undoing tab closures, and this bug is an enhancement request for allowing the 
browser to retain all tabs between sessions. Opera has both of these features, 
and Mozilla has neither.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
Summary: Add on option to restore all previous tabs on browser restart → Add an option to restore all previous tabs on browser restart

Comment 3

13 years ago

*** This bug has been marked as a duplicate of 159357 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.