hitting tab in print preview crashes [@ IsRootFrame]

VERIFIED FIXED

Status

()

--
critical
VERIFIED FIXED
14 years ago
8 years ago

People

(Reporter: ajschult784, Assigned: roc)

Tracking

({crash, regression})

Trunk
x86
Linux
crash, regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

Attachments

(2 attachments)

(Reporter)

Description

14 years ago
With linux suite trunk 2005060301, if I hit tab immediately after bringing up
print preview, it crashes.  This regressed between 6/1 and 6/2 builds and (based
on stack) is from bug 289250.
(Reporter)

Comment 1

14 years ago
Created attachment 185346 [details]
stacktrace

Comment 2

14 years ago
Related/dupe of bug 296413?
Flags: blocking1.8b3?
Created attachment 186436 [details] [diff] [review]
fix

Simple issue ... we die when traversal is already at the root. This brings this
call to IsRootFrame into consistency with the other calls.
Attachment #186436 - Flags: superreview?(bzbarsky)
Attachment #186436 - Flags: review?(bzbarsky)
Attachment #186436 - Flags: superreview?(bzbarsky)
Attachment #186436 - Flags: superreview+
Attachment #186436 - Flags: review?(bzbarsky)
Attachment #186436 - Flags: review+
Comment on attachment 186436 [details] [diff] [review]
fix

simple, no-risk crasher fix
Attachment #186436 - Flags: approval1.8b3?

Updated

14 years ago
Attachment #186436 - Flags: approval1.8b3? → approval1.8b3+
checked in
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Flags: blocking1.8b3?
Resolution: --- → FIXED
There is a crash that occurs on Windows trunk builds: bug 244128.

It happens when tab shifts focus.  Stack is here:
https://bugzilla.mozilla.org/attachment.cgi?id=186683
Verified FIXED with build 2005-08-06-06 on SeaMonkey trunk with Windows XP.
Status: RESOLVED → VERIFIED
Crash Signature: [@ IsRootFrame]
You need to log in before you can comment on or make changes to this bug.