URL not set in the address bar until the remote connection gets established

RESOLVED DUPLICATE of bug 231393

Status

()

Firefox
Address Bar
RESOLVED DUPLICATE of bug 231393
13 years ago
13 years ago

People

(Reporter: Caleb, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
It seems that if you load a site in a new tab, Firefox will try to establish a
connection and the tab's status will be set to "Loading...", but during that
process and upon a failure to do so the Address Bar will not show the URL of the
site.

This is hard to reproduce because you need a non-working site (whose DNS
resolves). I found out that with invalid URLs or sites that don't DNS resolve
you get an error message and the URL is displayed, but for this particualr case,
 you get no errors and the URL isn't displayed.

I've had this happen on this site: http://www.kdedevelopers.org/node/view/1129
but once it's back up I don't think that you'll be able to reproduce it that easily.

Pinging www.kdedevelopers.org while it did not load in Firefox responded
properly, so I think that Firefox is waiting for the HTTPD (which is probably
busy at the time).

I think that it is important to have the URL show up in the Address Bar because
failure to do so makes it very difficult to relod the page!

Comment 1

13 years ago

*** This bug has been marked as a duplicate of 231393 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.