Crash on exit in LastPageVisited pref callback

VERIFIED DUPLICATE of bug 29304

Status

()

P3
critical
VERIFIED DUPLICATE of bug 29304
19 years ago
19 years ago

People

(Reporter: phil, Assigned: sspitzer)

Tracking

({crash, verifyme})

Trunk
x86
Windows NT
crash, verifyme
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: fix in hand.)

(Reporter)

Description

19 years ago
I quit the app by closing the last open browser window, and crashed. Talkback id 
6075772. Looks like there's a pref callback for LastPageVisited on the stack, 
and I think sspitzer just added that code.
(Reporter)

Comment 1

19 years ago
Add crash, beta1 keywords.

I misstated that slightly. It's not a callback for that pref, it's a setting of 
that pref, which causes a callback in the PresContext
Severity: normal → critical
Keywords: beta1, crash
I'm curious about that stack.

alecf tells me that layout is registering a callback on all browser.* prefs, and
the last page visited pref does start with
browser.*

I'll look at the stack trace,, but to work around the problem (until we stop
registering callbacks for all of browser.*) would be
to change the name of the last page visited pref to be something not browser.*


Status: NEW → ASSIGNED
the quick fix is to rename that pref.  I'll check it in as soon as I can.
Whiteboard: fix in hand.
Target Milestone: M14

Comment 4

19 years ago
see bug 29304 for the browser.* bug
this is a duplicate.  I'm not going to change the pref name, I'm going to wait
for the real fix.

*** This bug has been marked as a duplicate of 29304 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE
well, it's not really a duplicate, but that other bug causes this problem to
show up.

on a related note, we aren't calling SetCharPref() with this pref on exit
anymore, due to other changes, so this crash won't happen any more.

we set the pref when we stuff it in the history, and not on exit, so that will
most likely make this bug go away.
Keywords: verifyme

Comment 7

19 years ago
[bugday] not really a duplicate... in the strictest sense, but it is fixed. :)
marking verfied. tested on winNT 2000031412.

There aren't good steps to reproduce, so I'm posting what I did to verify:
1) Launch Mozilla.
2) Change "Mozilla starts with" in preferences to "Last Page Visited"
3) Hit OK.
4) Close Mozilla.
*used to crash - I assume. But didn't for me*
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.