New message window defaults sender to the default mail account, not the active account

RESOLVED DUPLICATE of bug 64267

Status

RESOLVED DUPLICATE of bug 64267
14 years ago
14 years ago

People

(Reporter: ispiked, Assigned: mscott)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050603 Firefox/1.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050603 Firefox/1.0+

When composing a new message, whether it be opening a new message window via a
mailto link, the new message window button, Ctrl+M, etc. Thunderbird makes the
account in the "From" menu the default account. Note that this occurs even when
you are using a different account; i.e. have a folder selected from that account.

Reproducible: Always

Steps to Reproduce:
1. Make sure you're using multiple accounts and are using the non-default account.
2. Create a new message via the new message button, or via mailto links form an
external application.

Actual Results:  
The account in the "From" menu is the default account.

Expected Results:  
The account in the "From" menu needs to active account.

Tried this with the latest trunk and it still is not fixed. This could be
potentially harmful if you don't recognize this. Say the person you're sending a
message to does not know you by your default account. They could delete the
message or potentially not recieve it at all. 

I know there is an easy work-around for this, but it's a pain, and many people
may not even realize this is happening.

Comment 1

14 years ago
(In reply to comment #0)
> When composing a new message, whether it be opening a new message window via a
> mailto link, 

Yes.

> the new message window button, Ctrl+M, 

No, you are mistaken on this point.

> Thunderbird makes the account in the "From" menu the default account. 
> Note that this occurs even when you are using a different account; i.e.
> have a folder selected from that account.

When clicking a mailto: from a browser or other program, using the default is 
the only sensible action.  A mailto: from within a message body probably should 
result in the identity to which the message was sent, but it doesn't; that's the 
dupe.

*** This bug has been marked as a duplicate of 64267 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.