clicking on XPInstall link on mozilla.org + 2 other steps causes bad reflow

RESOLVED WORKSFORME

Status

()

P3
normal
RESOLVED WORKSFORME
19 years ago
18 years ago

People

(Reporter: hoju, Assigned: karnaze)

Tracking

({verifyme})

Trunk
x86
Other
verifyme
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

19 years ago
I am testing on build 2000022908

1. Go to http://www.mozilla.org

2. Now, click on the XPInstall link.  The link goes to:
news://news.mozilla.org/netscape.public.mozilla.xpinstall

The link will go nowhere, so you will still be at mozilla.org

3. now click on any whitespace on the page

4. now mouse over the XPInstall link and watch the page do a very goofy reflow


This is similar to a problem I had reported a long while back dealing with 
mousing over images:

http://bugzilla.mozilla.org/show_bug.cgi?id=14809


Jake

Comment 1

19 years ago
Changing component to tables. My guess is that an incremental reflow occurs and 
the table reflows differently
Assignee: troy → karnaze
Component: Layout → HTMLTables
QA Contact: petersen → chrisd

Comment 2

19 years ago
*** Bug 30126 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 3

19 years ago
In regard to bug 30126, there are other links on the mozilla home page that 
seem to be causing the same sort of reflows when you right click them.  In 
fact, right-clicking on just about ANY link on the page except for the left 
hand column of links and the "more" link for the status update causes strange 
reflows.

Jake

(Reporter)

Comment 4

19 years ago
bug 28553 seems to be related to this.  A fix has been checked in for that, 
supposedly, so let's see how that one turns out.

jake
I can reproduce this in M14, but it now works (20000324, W95). Given 
hoju@visi.com's comments, marking as such. 

Gerv
Status: UNCONFIRMED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → WORKSFORME

Comment 6

19 years ago
Adding 'verifyme' keyword
Keywords: verifyme

Comment 7

18 years ago
QA contact update
QA Contact: chrisd → amar
You need to log in before you can comment on or make changes to this bug.