Last Comment Bug 296689 - Paragraph direction auto-detection in input text widgets
: Paragraph direction auto-detection in input text widgets
Status: RESOLVED DUPLICATE of bug 218823
:
Product: Core
Classification: Components
Component: Layout: Text (show other bugs)
: Trunk
: All All
: -- enhancement (vote)
: Future
Assigned To: Mike Kaply [:mkaply]
:
:
Mentors:
http://lists.w3.org/Archives/Public/w...
Depends on: 218823
Blocks: Persian
  Show dependency treegraph
 
Reported: 2005-06-05 04:53 PDT by Behnam Esfahbod [:zwnj]
Modified: 2008-07-31 02:43 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Behnam Esfahbod [:zwnj] 2005-06-05 04:53:07 PDT
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050513 Fedora/1.0.4-1.3.1 Firefox/1.0.4
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050513 Fedora/1.0.4-1.3.1 Firefox/1.0.4

As Unicode TR9 says, direction (of bidi algorithm) of paragraphs should be
auto-detected from the first strong character of paragraph.

Reproducible: Always

Steps to Reproduce:
1. Open a page with TEXTAREA
2. Type in TEXTAREA in Latin and an RTL language
3. Make some paragraphs randomly

Actual Results:  
All paragraphs' direction is same.

Expected Results:  
Every paragraph's direction should be as TR9 says.
Comment 1 Eyal Rozenberg 2005-06-05 09:16:46 PDT
How is this not a dupe of 218823?
Comment 2 timeless 2005-06-09 16:34:36 PDT
i found bug 218823 comment 36 to be the most amusing, at best this bug is a
subset of that bug.
Comment 3 Prognathous 2005-06-21 05:58:53 PDT
(In reply to Behnam Esfahbod, comment #0)
> Expected Results:  
> Every paragraph's direction should be as TR9 says.

Actually, the TR9 says this:

> "When a higher-level protocol specifies the paragraph level, it is not
necessary to apply rules P2 and P3"

http://www.unicode.org/unicode/reports/tr9/#The_Paragraph_Level

HTML is one such higher-level protocol.

Behnam, if you want this in Mozilla (and it seems many of us do), you should
lobby Simon's suggestion and get the W3C to change their specs. Until then, I
don't see this implemented.

Prog.
Comment 4 Gervase Markham [:gerv] 2005-09-27 02:10:12 PDT
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/
Comment 5 Prognathous 2005-09-27 22:10:30 PDT

*** This bug has been marked as a duplicate of 218823 ***

Note You need to log in before you can comment on or make changes to this bug.