Closed Bug 296728 Opened 15 years ago Closed 15 years ago

CSS generated content cannot be selected and copied.

Categories

(Firefox :: General, defect)

x86
Windows XP
defect
Not set
normal

Tracking

()

VERIFIED DUPLICATE of bug 12460

People

(Reporter: chrisjhaig, Unassigned)

References

()

Details

(Keywords: testcase)

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.7.8) Gecko/20050511 Firefox/1.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

Trying to highlight text which is generated by CSS using the content property
isn't possible. Even using the 'select all' option will miss the CSS generated
content.

At the URL provided, I attempted to highlight and copy the URL (branded IRI on
the web site) so I could browser to the source page, but this wasn't possible in
Firefox 1.0.4.

As a site note, Opera 8 worked as expected.

Reproducible: Always

Steps to Reproduce:
1. Browse to a web site which used the CSS 'content' generation property (see
example).
2. Scroll to a quote which contains a 'Source IRI' (generated by CSS).
3. Attempt to highlight the URL (branded IRI on the example web site).

Actual Results:  
Text generated by CSS isn't highlighted or selectable.

Expected Results:  
CSS generated text to be highlighted in the same manor as the static text.
Attached file minimised testcase
try to select the url in red
Keywords: testcase

*** This bug has been marked as a duplicate of 12460 ***
Status: UNCONFIRMED → RESOLVED
Closed: 15 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.