history lists URL of previous page instead of current one with bfcache enabled

VERIFIED FIXED

Status

()

Core
Document Navigation
VERIFIED FIXED
13 years ago
10 years ago

People

(Reporter: Benoît, Assigned: Brian Ryner (not reading))

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win95; en-US; rv:1.8b2) Gecko/20050530
Build Identifier: Mozilla/5.0 (Windows; U; Win95; en-US; rv:1.8b2) Gecko/20050530

In History, the titles of pages you visited is that of the page you were on
before accessing it when exiting them with the Back button.

Say you are on Google. Now click on a bookmark that leads you to mozilla.org.
Press Back. Now go into your History, and look up your entry of
http://www.mozilla.org/. It will read "Google" instead of the site's title.

This happens only with bfcache enabled.

Reproducible: Always

Steps to Reproduce:
1. Load a page. Any page.
2. Click on a link on that page, or click a bookmark.
3. Press Back.
4. Look up the page you just visited in History.

Actual Results:  
The title listed is that of the previous page.

Expected Results:  
Listed the last visited page's title.
(Reporter)

Updated

13 years ago
Blocks: 274784
OS: other → Windows 95

Comment 1

13 years ago
Confirming in Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b2) Gecko/20050529
build.

Comment 2

13 years ago
Can easily reproduce it, following reporter's steps on build 20050607/WinXP. The
history entry'stitle is corrected only when you click on it (and the page is
loaded again). This breaks an essential History feature. Additionally it might
be the cause of bug 293235. ->NEW, Severity->Normal, OS->All.
Perhaps a fallout of an already reported bfcache bug that it's too technical for
us non-hackers to understand. If that is the case, better don't duplicate this
one because the summary makes it easy to verify whether it has been fixed or not.
Severity: trivial → normal
Status: UNCONFIRMED → NEW
Component: History: Global → History: Session
Ever confirmed: true
OS: Windows 95 → All

Comment 3

13 years ago
forget my speculation about bug 293235. Doesn't seem related, the uri is
correctly stored.
(Assignee)

Comment 4

13 years ago
Created attachment 186714 [details] [diff] [review]
move the title-restore later

Don't restore the title until mOSHE and mCurrentURI are updated to the new
page.
Assignee: nobody → bryner
Status: NEW → ASSIGNED
Attachment #186714 - Flags: superreview?(bzbarsky)
Attachment #186714 - Flags: review?(bzbarsky)
(Assignee)

Comment 5

13 years ago
Comment on attachment 186714 [details] [diff] [review]
move the title-restore later

darin, feel free to r/sr as well if boris can't get to this
Attachment #186714 - Flags: superreview?(bzbarsky) → superreview?(darin)
(Assignee)

Comment 6

13 years ago
Comment on attachment 186714 [details] [diff] [review]
move the title-restore later

switching reviewers, boris is away for awhile
Attachment #186714 - Flags: review?(bzbarsky) → review?(cbiesinger)

Comment 7

13 years ago
Comment on attachment 186714 [details] [diff] [review]
move the title-restore later

Very obvious fix.  r+sr=darin
Attachment #186714 - Flags: superreview?(darin)
Attachment #186714 - Flags: superreview+
Attachment #186714 - Flags: review?(cbiesinger)
Attachment #186714 - Flags: review+
(Assignee)

Comment 8

13 years ago
Comment on attachment 186714 [details] [diff] [review]
move the title-restore later

Requesting approval for fastback fix. Does not impact non-fastback.
Attachment #186714 - Flags: approval1.8b3?

Updated

13 years ago
Attachment #186714 - Flags: approval1.8b3? → approval1.8b3+
(Assignee)

Comment 9

13 years ago
checked in
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED

Comment 10

13 years ago
verified fixed with FF 20050621 on WinXP.
Status: RESOLVED → VERIFIED

Updated

10 years ago
Component: History: Session → Document Navigation
QA Contact: history.global → docshell
You need to log in before you can comment on or make changes to this bug.