ksfo.com - Formatting of Page Graphics Not Right-- Display of Horizontal Rule

RESOLVED WORKSFORME

Status

Tech Evangelism Graveyard
English US
--
minor
RESOLVED WORKSFORME
13 years ago
3 years ago

People

(Reporter: moc, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050605 Firefox/1.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050605 Firefox/1.0+

Hello,

Under the menu bar of this web page we see, in MS IE, a "horizontal rule", or, a
graphic element that is the functional equivalent of a horizontal rule.

Switching to the latest FireFox overnite build, I still see that the horizontal
rule is, in FireFox, displaced upward so as to be aligned across the middle of
the menu labels, thus appearing to strike through them.

I have looked at the source for this page and the Mozilla page on standards
compliance, but I don't know enough about HTML standards to figure out if the
page is compliant or not. There is no !DOCTYPE HTML PUBLIC declaration, so
FireFox must be operating in the Quirks mode.

So the first question would be 'is this really a bug or is it just a webmaster
using code that is too quirky'?

-Mike O'Connor

Reproducible: Always

Steps to Reproduce:
1.Just browse to the page www.ksfo.com.
2.
3.

Actual Results:  
There is a horizontal rule that is drawn through the menu items.

Expected Results:  
The horizontal rule should be drawn under the menu items. 

KSFO did recently extensively revise their page. Perhaps their webmaster will
eventually find a way to make it work with FireFox. I am writing because the
poop at http://www.mozilla.org/docs/web-developer/faq.html#margins, the only
stuff that I can find on the FireFox page for webmasters that seems as though it
might be applicable, isn't applicable because (as is related above) the browser
should be operating in Quirks mode.
Component: General → Layout
Product: Firefox → Core
QA Contact: general → layout
Version: unspecified → Trunk

Comment 1

13 years ago
the menus and the horizontal rule (actually an image) are in consecutive rows of
a table.  But the cell containing the menus contains a table whose cells contain
DIVs which contain the menu heading images.  The DIVs containing the images are
styled to be 0px and so (with nothing else to give them height) the table cells
and the table are too short, so the top-level cell is too short and the images
overflow the cell and overlap the image in the next row.

http://www.ksfo.com/stylesheets/Nav.css

==> Tech Evang
Assignee: nobody → english-us
Status: UNCONFIRMED → NEW
Component: Layout → English US
Ever confirmed: true
OS: Windows XP → All
Product: Core → Tech Evangelism
QA Contact: layout → english-us
Hardware: PC → All
Summary: Formatting of Page Graphics Not Right-- Display of Horizontal Rule → www.ksfo.com - Formatting of Page Graphics Not Right-- Display of Horizontal Rule
Version: Trunk → unspecified

Comment 2

13 years ago
Conforming summary to TFM item 10 at 
http://www.mozilla.org/projects/tech-evangelism/site/procedures.html#file-new
Summary: www.ksfo.com - Formatting of Page Graphics Not Right-- Display of Horizontal Rule → ksfo.com - Formatting of Page Graphics Not Right-- Display of Horizontal Rule
(Reporter)

Comment 3

13 years ago
(In reply to comment #1)
> the menus and the horizontal rule (actually an image) are in consecutive rows of
> a table.  But the cell containing the menus contains a table whose cells contain
> DIVs which contain the menu heading images.  The DIVs containing the images are
> styled to be 0px and so (with nothing else to give them height) the table cells
> and the table are too short, so the top-level cell is too short and the images
> overflow the cell and overlap the image in the next row.
> 
> http://www.ksfo.com/stylesheets/Nav.css
> 
> ==> Tech Evang


Andrew, thanks for your help. I'm not yet competent in BugZilla protocol (I'm a
power user, not a programmer and this is very dweeby), so I don't necessarily
get what it is that I should be doing now, in response to the email follow-up
advisories that I have received. I did however previously write to the KSFO
webmaster (it's a company, not an individual), in a spirit of evangelism I
suppose, and I did refer him to the FireFox page
http://www.mozilla.org/docs/web-developer/faq.html. If I hear back from an
actual person rather than an ebot I'll pass along your detailed observations.

-Mike O'Connor

Comment 4

4 years ago
Seems fixed / redesigned.
[closeme]
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.