Inbox folder is set to sync files to local cache when going offline and some meesages don't get cached

RESOLVED WORKSFORME

Status

--
major
RESOLVED WORKSFORME
14 years ago
9 years ago

People

(Reporter: razl2, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050513 Fedora/1.0.4-1.3.1 Firefox/1.0.4
Build Identifier: tbird version 1.0+ 20050531

I have my inbox set to have all messages sync'ed when I go offline.  When I do
go offline, there are some messages that don't get cached.  Even if I manually
use the sync command before I go offline, the messages still don't get cached.

I created a debug log for the IMAP and IMAPOFFLINE at level 5.  Toward the end
of the log I was viewing a message that wasn't in the cache.

Reproducible: Always

Steps to Reproduce:
1.Select a folder to sync when going offline
2.Go offline
3.

Actual Results:  
Some messages don't get cached as they are supposed to

Expected Results:  
All messages in the selected mailbox should be downloaded to the local cache.
(Reporter)

Comment 1

14 years ago
Created attachment 185440 [details]
This is the log of the failure when I tried to read a message that wasn't there

I ran a log for IMAP and IMAPOFFLINE at level 5.  I then proceeded to go
offline.  Toward the end of the log, I was attempting to read a message that
should have beeb cached but wasn't.

Comment 2

13 years ago
I can confirm this bug - it appears to be a duplicate of 296154.

I see the same problem frequently. I try using File->Offline->Download selected
messages, to force a sync, but that usually does not help.

Comment 3

13 years ago
What build are you running? I fixed a problem like this a couple months ago, iirc.
QA Contact: front-end

Comment 4

10 years ago
In 2.0.0 builds (e.g. 2.0.0.16), I still see this problem. I must admit I don't use "offline" as much as
I used to, since it's pretty easy these days to be online. However, I do
tend to find that it gets screwed up, particularly after doing a delete
trash and compact folders. I sometimes have to "rebuild index" to get
everything refreshed again, which is expensive, as it has to potentially
download a lot of things I already had downloaded... 

Updated

10 years ago
Assignee: mscott → nobody
Component: Mail Window Front End → Backend
Product: Thunderbird → MailNews Core
QA Contact: front-end → backend

Comment 5

10 years ago
andrew, razl2, can you confirm problem is gone using current nightlies and beta? 
 backup your profile before using ... 
 http://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly/latest-trunk/

Comment 6

9 years ago
andrew writes he no longer sees this, starting with beta 3.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME

Comment 7

9 years ago
I've also checked this in beta 4, and it continues to work very well.
You need to log in before you can comment on or make changes to this bug.