"Allow this time" for "Allow websites to install software"

RESOLVED DUPLICATE of bug 252830

Status

()

Firefox
Preferences
--
enhancement
RESOLVED DUPLICATE of bug 252830
13 years ago
7 years ago

People

(Reporter: choonkeat, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

Many firefox hackers DIY and publish extensions on their blog or etc, and such
websites may not be preferably white-listed permanently. 

As user try and install such independent sites, the notion of 'whitelist' to
protect unauthorized install is diluted. 

Sometimes, we just want to install this particular extension, from this
particular site, this time. Not other plugins from the same guy or whatever.

Reproducible: Always

Steps to Reproduce:
1. Click on "xpi" link
2. See "Edit Options" button on warning banner

a) add a "allow this once" button to banner, or to the "Edit Options" dialog.

Comment 1

13 years ago
It's so close to mine I'm just going to dupe it to bug 293559 , please comment
there.

*** This bug has been marked as a duplicate of 293559 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

*** This bug has been marked as a duplicate of 252830 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.