the page is not rendered correctly with build 2000022908

VERIFIED DUPLICATE of bug 29739

Status

P3
normal
VERIFIED DUPLICATE of bug 29739
19 years ago
14 years ago

People

(Reporter: o.smolsky, Assigned: cbegle)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

19 years ago
When this (or almost any other page) is opened, the
hirizontal scroll bar shows that the page doesn't fit
in the current window. However, after resizing forward
and back the scroll bar disappears.

BTW, this behaviour was not present in older builds -
eg 2000022008 was fine.

Comment 1

19 years ago
Created attachment 5914 [details]
a lame testcase

Comment 2

19 years ago
I can confirm this on Windows 95, build 20000022908 at the those pages.  In fact 
most any page that includes a vertical scroll bar.  Re-sizing to the same size 
makes the horizontal scroll bar go away.  Re-load and it comes back.

The attached test case is just a basic HTML file with a bunch of <br>'s for 
content.  Loading this in a 800x600 browser gives vertical and horizontal scroll 
bars.  

I think what is happening is that when the vertical scroll bar is created, the 
horizontal scroll bar is created to show the 1/4 inch of page that the vertical 
scroll bar is now covering.  I guess it should probably do a re-flow or 
something instead.

Comment 3

19 years ago
This is the bug about drawing tables with width=100% wider than the window in 
the beginning. Resizing height of window lead to a really 100% table, which 
moves things around a lot.
There are so many dupes of this around, that I'll just start cleaning up 
somewhere.

*** This bug has been marked as a duplicate of 29739 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE

Comment 4

19 years ago
verified duplicate of 29739
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.