Feature request: Disable JavaScript particular functions/methods for particular domains

RESOLVED WONTFIX

Status

()

Firefox
Preferences
--
enhancement
RESOLVED WONTFIX
13 years ago
13 years ago

People

(Reporter: Oz, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050518 Firefox/1.0.4
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050518 Firefox/1.0.4

The user should be able to disable particular JavaScript functions/methods for
particular domains using the "Preferences" dialogs "Web Features" section. In
this section the categoies "Enable JavaScript" "Advanced..." button should lead
to a more complicated but feature enriched dialog. Like in the "Allowed Sites"
dialog from "Block Popup Windows" there should be the possibility to enter a
domain name. Additionally it should be able to enter a function or maybe several
functions separated by semikola. The entered data may then be committed into a
table (like in the "Allowed Sites" dialog) by the button "Disable".

There should also be a possibilty to generally disable/enable JavaScript
(without wiping/reentering data).

When possible the domain name this feature is matching against should be the one
 in the adress bar. As a result that would mean (i)frames or included JavaScript
files hosted in other domains would be disabled without researching and entering
data for each of their domains.

Example:
Disable the JavaScript method "write" for the domain "mercateo.com".

The target:
Since Popup windows may be blocked by Firefox they keep comming up with those
full screen "DIV" banners to annoy each of us with their stoopit comercial
stuff. As if we would buy that **** just for they put it in front of the stuff
we like...

It would also be cool to lock variables/attributes to a special or their initial
 value...

Reproducible: Always

Steps to Reproduce:

Comment 1

13 years ago
We already have CAPS, see
<http://www.mozilla.org/projects/security/components/ConfigPolicy.html>. We
still need a good user interface though, see bug 38966 for Seamonkey (didn't
found one for FireFox).
I think this should be better done in an extension.
Joe User doesn't need something like this.

The backend is already there, moving it to preferences
Component: Security → Preferences
QA Contact: firefox → preferences
the newer versions of adblock can block divs too.
http://bene.sitesled.com/install.htm

WONTFIX ?
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.