Sort by thread: Unread column shows negative numbers

VERIFIED WORKSFORME

Status

SeaMonkey
MailNews: Message Display
P3
normal
VERIFIED WORKSFORME
18 years ago
13 years ago

People

(Reporter: lchiang, Assigned: Bienvenu)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Sort by thread: Unread column shows negative numbers

I'm seeing this in News.  I don't see this in Mail, but I haven't yet narrowed 
down to the pattern or why this is occurring.

win32 2000-02-28-09-m15 commercial build

1) Select a newsgroup.  I've tried .builds and .mail-news on news.mozilla.org
2) Sort by thread
3) Notice in the unread column in the thread pane, you will see negative numbers 
such as -4, -2, etc.

I also see some positive numbers so I'm not sure why some threads show negative.
(Reporter)

Comment 1

18 years ago
Ok, it appears that any thread where all the msgs are already read show a 
negative number indicating the number of messages in the thread. For example, if 
a thread has 4 messages and I've read all of them, then -4 shows in the unread 
column.

If it matters, I regularly do a "Mark All Read" on these newsgroups.
(Reporter)

Comment 2

18 years ago
actually, sometimes the count is off by 1.  I haven't found out a pattern yet

Comment 3

18 years ago
Reassign to putterman
Assignee: phil → putterman

Comment 4

18 years ago
reassigning to bienvenu.

This sounds like a bug we had a while ago.  Of course, this could be the same 
bug and the .msf files were never deleted.
Assignee: putterman → bienvenu
(Reporter)

Comment 5

18 years ago
I have never deleted .msf files before.  Let me go and add a new newsgroup (so 
no old .msf file hanging around) and see if this problem occurs.
(Assignee)

Comment 6

18 years ago
seems like a dup to me - I can't recreate it. I'll go find the other bug.
Status: NEW → ASSIGNED
(Assignee)

Comment 7

18 years ago
maybe a dup of 25343
(Reporter)

Comment 8

18 years ago
It may be a dupe.  I have to monitor that new newsgroup I added for a day or so 
to see if negative numbers show up.
(Assignee)

Comment 9

18 years ago
any progress on reproducing this?
(Reporter)

Comment 10

18 years ago
I can't see this in the new newsgroup that I had added and marked things unread. 
Go ahead and close this one out.  If I do get steps from scratch, I'll reopen.
(Assignee)

Comment 11

18 years ago
works for me, probably a dup of an earlier bug
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME

Comment 12

18 years ago
assign it to fenella
QA Contact: lchiang → fenella

Comment 13

18 years ago
Linux (2000-04-26-08 M16)
Win32 (2000-04-26-09 M16)
Mac (2000-04-26-11 M16) mozilla (commercial build broken)
I am going to verify this bug because Unread column does not show negative
number any more.  However, there is a different problem. Please see bug 37334.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.