memory not cleaned when tabs closed

VERIFIED DUPLICATE of bug 131456

Status

()

Firefox
Tabbed Browser
--
major
VERIFIED DUPLICATE of bug 131456
13 years ago
12 years ago

People

(Reporter: stefano galli, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.7) Gecko/20050421 Firefox/1.0.3 (Debian package 1.0.3-2)
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.7) Gecko/20050421 Firefox/1.0.3 (Debian package 1.0.3-2)

When creating new tabs, memory is allocated. It grows as you navigate, but when
closing tabs, memory consumption does not decreases. It looks like some "free"
are missing!
Let Firefox running an entire day, and you'll have you memory filled with garbage!

Reproducible: Always

Steps to Reproduce:
1. open say 8 tabs and open some pages in them
2. check memory consumption
3. close some tabs
4. check memory consumption again, it did not grow

Actual Results:  
Memory consumption grows and grows...

Expected Results:  
...after closing tabs, the memory occupied by that tab should be freed!

Comment 1

13 years ago

*** This bug has been marked as a duplicate of 131456 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED

Comment 2

12 years ago
i have experienced this bug also, sometimes have my Firefox [Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7] running for a couple of days at a time and several tabs open (could be more than 50 open/close over a weekend).  when i eventually close the app it might take upto (or more!) 30 mins for firefox to close down whilst consuming nearly 100% processing power and over 100MB memory.
I generally follow steps as previously reported and observe similar results.
You need to log in before you can comment on or make changes to this bug.