Provide support for x86 based Macs

RESOLVED FIXED

Status

RESOLVED FIXED
14 years ago
9 months ago

People

(Reporter: u49640, Assigned: jaas)

Tracking

Trunk
PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050602 Firefox/1.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050602 Firefox/1.0+

Apple switches OSX from PPC to x86 (see link, sorry, no better available)

Mozilla should provide a "FAT Binary" (or "Universal Binary as Steve called it)
to provide PPC and x86 code for the Mac Version (for all Apps)

Reproducible: Always

Steps to Reproduce:




(i have no idea, what category is the right one, so sorry for posting it in this
one)

Comment 1

14 years ago
Should probably go in Core/Build Config.
(Reporter)

Comment 2

14 years ago
ok, moving it over to Core/BuildConfig
Component: General → Build Config
Product: Firefox → Core
Version: unspecified → Trunk
(Assignee)

Updated

14 years ago
Assignee: nobody → joshmoz
(Assignee)

Comment 3

14 years ago
Please try to keep the comments in this bug to a minimum - I am predicting that
it will get really long. We are well aware of how to create universal binaries,
and don't worry - we will absolutely support x86 macs in the best way possible.
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
*** Bug 308880 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

13 years ago
Hardware: PC → Macintosh
(Assignee)

Comment 5

13 years ago
Information on the progress of support for x86 Macs can be found here:

http://wiki.mozilla.org/Mac:Intel

Comment 6

13 years ago
This is so totally fixed.
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED

Updated

9 months ago
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.