Note: There are a few cases of duplicates in user autocompletion which are being worked on.

DOM API: typeof HTMLObjectElement is 'function'

VERIFIED DUPLICATE of bug 268945

Status

()

Firefox
General
VERIFIED DUPLICATE of bug 268945
12 years ago
12 years ago

People

(Reporter: howard, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

I've not done an exhaustive test, but for most HTML DOM elements (HEAD, BODY, DIV,
etc.), the expression

    typeof elem

is 'object'. For HTMLObjectElement, HTMLAppletElement (and HTMLEmbedElement!),
the expression is 'function'. However, none of the usual properties of a
function object (apply, call, length) are defined.

Reproducible: Always

Steps to Reproduce:
1. elem = document.createElement('object');
2. typeof elem;
3.

Actual Results:  
'function'

Expected Results:  
'object'

Comment 1

12 years ago
Similar to (duplicate of?) Bug 268945.
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/

Comment 3

12 years ago

*** This bug has been marked as a duplicate of 268945 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 4

12 years ago
Created attachment 197617 [details]
Test html file
(Reporter)

Comment 5

12 years ago
(In reply to comment #2)
> This is an automated message, with ID "auto-resolve01".
> 
> This bug has had no comments for a long time. Statistically, we have found that
> bug reports that have not been confirmed by a second user after three months are
> highly unlikely to be the source of a fix to the code.

[etc.; snipped the auto-resolve).

As asked, this behavior is unchanged in Firefox 1.5beta.

   <html><head><title>x</title><script type="text/javascript">
   var x = document.createElement('object');
   alert('typeof is ' + typeof x + '\n' + navigator.userAgent);
   </script></head><body></body></html>
    
gives:

    typeof is function
    Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b4) Gecko/20050908 Firefox/1.4
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.