tab through form elements skips and ignores fields

RESOLVED DUPLICATE of bug 187508

Status

()

Firefox
Shell Integration
RESOLVED DUPLICATE of bug 187508
13 years ago
13 years ago

People

(Reporter: rj hornsby, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

Using MacOSX 10.4.1 + FF 1.0.4, in every page I've been able to find, FF skips
over non-text input fields (select, radio, checkbox) when attempting to tab (key
0x09) through the form.  Two examples of pages that don't work right:

  http://www.w3schools.com/html/html_forms.asp
  https://bugzilla.mozilla.org/enter_bug.cgi?product=Firefox



Reproducible: Always

Steps to Reproduce:
1.  Visit a webpage with a mix of form elements
2.  Attempt to complete a field and press 'tab' to get to the next field
3.  Hunt for your cursor/focus as it is either on the next form element of type
'text' or is in the location bar at the top of the window

Actual Results:  
The cursor and focus move to the wrong element or out of the form completely,
skipping over the next element in order. 

Expected Results:  
The cursor and focus should move to the next element of the form, not skipping
elements, unless specifically indicated by tabindex properties in the HTML.

Sorry if this is NOTABUG and is actually some obscure setting, as I'm new to OSX
coming from Linux on the desktop.  This seems like awfully bizarre default
behavior if that is the case.  Thanks for your patience.

*** This bug has been marked as a duplicate of 187508 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.