PowerPC Linux should support native PowerPC atomic instructions (lwarx/stwcx.)

RESOLVED WONTFIX

Status

()

Core
JavaScript Engine
--
enhancement
RESOLVED WONTFIX
13 years ago
5 years ago

People

(Reporter: kevdig, Unassigned)

Tracking

Trunk
PowerPC
Linux
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux ppc; en-US; rv:1.8b2) Gecko/20050601
Build Identifier: Mozilla/5.0 (X11; U; Linux ppc; en-US; rv:1.8b2) Gecko/20050601

See 296878, which was filed against NSPR for the same reason

Reproducible: Always
(Reporter)

Updated

13 years ago
Blocks: 296878
(Reporter)

Comment 1

13 years ago
patches have been attached to 296878

Updated

13 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Dependends on, not blocks, relation.

Anyone want to adapt the patch in bug 296878 to jslock.c's js_CompareAndSwap,
for Mac OS X?

/be
No longer blocks: 296878
Depends on: 296878

Updated

12 years ago
Blocks: 307953
(In reply to comment #2)
> Dependends on, not blocks, relation.
> 
> Anyone want to adapt the patch in bug 296878 to jslock.c's js_CompareAndSwap,
> for Mac OS X?

Clue to self: read patch first, then comment.

Looks like this bug will be fixed when its dependency is fixed.  :-)

/be

Updated

12 years ago
Flags: testcase-

Comment 4

7 years ago
Hi,

I added a patch which adds this support here. The only thing left is endianness in data_pack.cc

https://bugzilla.mozilla.org/attachment.cgi?id=504649&action=diff

Comment 5

5 years ago
Not a tier 1 platform anymore.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.