top talkback -Crash when encounter applet and Java not installed

VERIFIED FIXED in M16

Status

Core Graveyard
Java: OJI
P3
critical
VERIFIED FIXED
18 years ago
7 years ago

People

(Reporter: Phil Peterson, Assigned: av (gone))

Tracking

({crash})

Trunk
x86
Windows NT
crash

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [PDT+] fix in hand (need review and approval))

Attachments

(3 attachments)

(Reporter)

Description

18 years ago
Using 2/29 build on Windows NT

1. Install Seamonkey without Java
2. Read warren's digitalMASS email 
3. Boom.

Talkback ID 6082790 shows nsPluginInstanceOwner::GetParameter() on the tip of 
the stack trace.
(Reporter)

Comment 1

18 years ago
Created attachment 5907 [details]
Full stack trace
(Reporter)

Comment 2

18 years ago
Created attachment 5908 [details]
Message which crashes

Comment 3

18 years ago
Will try to get to it soon, but right now, verifying that the Java VM is working
well is the top priority.
Status: NEW → ASSIGNED
Target Milestone: M16
(Reporter)

Comment 4

18 years ago
cc av@netscape.com on the chance that this is a plugins issue rather than an OJI
issue.
(Reporter)

Comment 5

18 years ago
I crashed again on http://www.widespreadpanic.com trying to load a page with a 
Java applet. Same stack trace. I'm getting the feeling that we just don't work 
without Java. If that's the case, I think we should consider this bug for beta1.
(Reporter)

Updated

18 years ago
Keywords: beta1
(Reporter)

Comment 6

18 years ago
Reassign to av, cc amusil
Assignee: drapeau → av
Status: ASSIGNED → NEW
Summary: Crash when mail contains applet and Java not installed → Crash when encounter applet and Java not installed
Whiteboard: [PDT+]
(Assignee)

Comment 7

18 years ago
phil, I have trouble reproducing it. What exactly should I do?
(Reporter)

Comment 8

18 years ago
1. Install Seamonkey without Java
2. Load http://www.widespreadpanic.com
3. Click on image to enter site
4. boom

Comment 9

18 years ago
Created attachment 6255 [details]
some user comments/site info about this crash

Comment 10

18 years ago
http://climate/reports/reporttemplate.cfm?style=0&reportID=1090
found 5.0nsPluginInstanceOwner::GetPar (170 Incidents)  in the database.
looks like some form of this crash happens on several sites with
several m14 and post m14 users
Summary: Crash when encounter applet and Java not installed → top talkback -Crash when encounter applet and Java not installed
(Assignee)

Comment 11

18 years ago
phil, I still see no boom. Is there any chance that SeaMonkey is trying to pick 
up older Java plugin from 4.x installation, which is known to be incompatible? I 
don't have it on my machine maybe this is a reason I don't crash. Could you try 
to, say, rename plugin folder in your 4.x install and see if you still crash?
(Reporter)

Comment 12

18 years ago
Yep, that seems to be the root of the problem. I renamed the Plugins directory
from 4.72 and didn't crash. Then I renamed it back again, and we crashed again.

Not sure what you mean by "known to be incompatible" though. Seems like
Seamonkey has to run on machines which have 4.x installed on them...
(Assignee)

Comment 13

18 years ago
Right. But is not it going to be distributed with Java?
(Reporter)

Comment 14

18 years ago
Let me re-state: Seems like Seamonkey without Java has to run on machines which
have 4.x installed on them. There are several installation options which do not
include Java.

If you believe that crashing when Java is not installed is ok for beta1, you can
remove the PDT+ and the PDT will reevaluate the bug in light of what we've learned.
(Assignee)

Comment 15

18 years ago
Hm... As per current implementation, SeaMonkey looks for plugins in 4.x 
installation too. Option of 'not including Java' sounds weird to me now. Adding 
ekrock.

Adding drapeau@eng.sun.com to the cc list. George, I think new Java plugin works 
with 4.x. Would it make sense to replace the older one in 4.x installation 
during SeaMonkey install?

Comment 16

18 years ago
av: I'll ask the JDK product folks for their opinion on this.  It's not really
my call, although your idea is an interesting one.  I don't know if it fixes
this bug, but I do like the idea that people would have a single Java plug-in
for both versions of the browser.
(Reporter)

Comment 17

18 years ago
Can't we fix Seamonkey so it only accepts a compatible Java plugin?

I'd sure hate to have Seamonkey potentially disable 4.x installations if
whacking the 4.x Java with a new Java didn't work. Unless that's had a ton of
testing I'm not aware of, it seems pretty high risk.
Agree with Phil that we should definitely not incur the added risk for beta1 of 
having the Seamonkey installer overwrite whatever Java-support plug-in is 
present in the Nav4 installation. There is simply too high a risk of hosing 
someone's Nav4 installation and no time to test this.

Instead, we need to make sure that the plug-in detection code (which currently 
scans the mozilla plugins directory first, then the Nav4 plugins directory) 
ignores any Java plug-in found in Nav4. Can this be easily done?

Updated

18 years ago
Severity: major → critical
Keywords: crash
(Assignee)

Comment 19

18 years ago
Yes, it's sorta one-liner. I can ignore npjava*.dll's in 4.x dir by their names. 
Alternatively, it can be done by mime types.
(Assignee)

Comment 20

18 years ago
I have a fix. Can check it in as soon as I get it reviewed and approved.

Updated

18 years ago
Whiteboard: [PDT+] → [PDT+] fix in hand

Updated

18 years ago
Whiteboard: [PDT+] fix in hand → [PDT+] fix in hand (need review and approval)

Comment 21

18 years ago
does this also affect linux, cause the javaplugin from blackdown causes a crash
on startup. I thought the plugin arch was backwards compatible.

sPluginFile(/home/sford/mozilla/dist/bin/plugins/javaplugin.so)
LoadPlugin() /home/sford/mozilla/dist/bin/plugins/javaplugin.so returned 826a358

Comment 22

18 years ago
As of 3/9, this was listed as fix in hand, waiting for review.  Who is doing the
review and not responding?  We need to get this landed... the beta  train needs
to chug along.
Thanks,
Jim
(Assignee)

Comment 23

18 years ago
I will check it in today.

Comment 24

18 years ago
av - let me know if you need a review
(Assignee)

Comment 25

18 years ago
The fix is in both the branch and the tip.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 26

18 years ago
Verified.  No longer crashes in build 2000031506 beta build.  
Status: RESOLVED → VERIFIED
(Reporter)

Comment 27

18 years ago
Works for me now too, using the 3/16 beta1 branch build.

Updated

7 years ago
Component: Java: OJI → Java: OJI
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.