download manager window reacts slowly and stops getting data while "Save As" dialog is active

VERIFIED DUPLICATE of bug 74331

Status

()

defect
--
major
VERIFIED DUPLICATE of bug 74331
14 years ago
11 years ago

People

(Reporter: tachyon.eagle, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050606 Firefox/1.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050606 Firefox/1.0+

while downloading one file from FTP or HTTP, when I choose "Save Link As" and
dialog of destination choice appears, from that moment download manager starts
reacting very slowly (but downloads can still be canceled,paused,removed), it's
quit hard to select certain file,that it gets highlight,
but most important thing :
the actual downloads in background are quite stopped down (0 - 150 bytes/second
on local host or lan connections) from getting more data bytes, this may cause
connection timeout, if user accidentaly left one such dialog on screen and
forgets it.

I think it may be related to Bug 289540 - download manager takes only one
listener my knowledge in this is limited.

Linux:
I've tried Fireofox 1.0.3-4 (Fedora Core 4 test 3 release package) and it
suffers the same, data stops flowing.

win32:
I've tried stable release of Firefox  1.0.4 and latest 1.1 snapshot (06.06.2005)
and both are affected = downloads are freezed. 
Mozilla seems to work it out ok . (latest snaphot and even older releases)



Reproducible: Always

Steps to Reproduce:
1. choose to download a file large enough that it will take a while to download it
2. use "Save Link As" on some other element on any page and leave destination
dialog open to see effects


Actual Results:  
download manager is slowed down, data flow is freezed 

Expected Results:  
handle multiple things at once, not freezing one or another

Comment 1

14 years ago
Duplicate of (bug 271425 ->) Core bug 74331?

Comment 2

14 years ago

*** This bug has been marked as a duplicate of 74331 ***
Status: UNCONFIRMED → RESOLVED
Closed: 14 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.