poor scrolling div support - lag when scrolling or changing pages on a div with overflow

RESOLVED WORKSFORME

Status

()

--
minor
RESOLVED WORKSFORME
14 years ago
14 years ago

People

(Reporter: nodmercinary, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

The page http://guitartabrequest.com/tab/pinkfloyd/thewallpartii/ has a div I
created with a scroll bar. There is a significant lag (espcially when compared
to IE) on the scrolling div. You notice this when you scroll, and you also
notice this when you change pages. When you are on a different browser window
and switch to the one with my url the div lags and takes a second or so to
actually display the data (instead of the previous page glued onto the div space
due to lag). I went to the forums first to address this issue. They said to
enable smooth scrolling (which should be enabled by default, please).. did this
and there was still a problem. ALSO, you can't use the arrow keys to scroll up
or down on this div. I feel the problem is over lack of support for this
feature. I'm not ranting, I love firefox, just wish you guys would address this
issue and continue to improve. Thanks.

Reproducible: Always

Steps to Reproduce:
1. Go to the provided URL.
2. Scroll where the main data/TAB is located.
3. Repeat above steps in IE to see the difference.

Actual Results:  
IE performed better, and firefox seemed as though they just threw this feature
together without concern of what it would be like. IE rarely performs better,
but in this case, they did.

Expected Results:  
FF to display it perfectly like it does everything else.
(Reporter)

Updated

14 years ago
Alias: div-Overflow-Support
WFM Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050606
Firefox/1.0+

Could you verify this with a nightly build? http://www.mozilla.org/developer
WFM Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b2) Gecko/20050607
Firefox/1.0+ ID:2005060708
This has been fixed on the trunk (for firefox 1.1) -- and a note to the future,
please don't give bugs an alias; that's for devs to do.
Alias: div-Overflow-Support
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 3

14 years ago
(In reply to comment #2)

trunk?

(Reporter)

Comment 4

14 years ago
OK, I got the new firefox... Deer Park? And the scrolling is fixed.. but it is
blowing out my images for no reason. Take a look at the same URL I submitted.
I don't know why there's an extra bit next to the scrollbar -- i haven't taken
the webpage apart to see if it's expected behaviour or not. But never-the-less,
the original issue that this bug was filed to cover has been fixed, so the bug
has been marked as so. Any other issue should be filed in a new bug (after
searching for an existing bug first).
You need to log in before you can comment on or make changes to this bug.