Closed Bug 296957 Opened 15 years ago Closed 15 years ago

Checking for updates creates blank window that states: updates found - nothing listed

Categories

(Toolkit :: Add-ons Manager, defect)

x86
Windows XP
defect
Not set

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: jmjjeffery, Assigned: robert.strong.bugs)

Details

(Keywords: regression, Whiteboard: pending completion update UI from BenG, bug 296868)

Attachments

(1 obsolete file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050607 Firefox/1.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050607 Firefox/1.0+

Open the EM and highlight an extension.
Firefox will check and advise that updates are found but the list is 'blank'
Button to Install updates now is highlighted, clicking 'Install Now' states that
Updates are complete, restart Firefox to complete.

No update takes place. 

Reproducible: Always

Steps to Reproduce:
1.Open EM
2.Highlight any extension and choose 'Update'
3.Returns with 'Update to Extensions/Themes found' but the list of extensions
that need an update is blank.  Install now button is 'active', clicking Install
results in no updates taking place, but advises that updates are complete,
please restart Firefox to activate.

Actual Results:  
No updates were applied.  No extensions were listed when checking for update.

Expected Results:  
Updated the Extension if update is available, or advised that No updates are found.
The software update patches are in the process of being landed. Things are not
likely to work until after they are all in.
This regressed from 292566 Move Extension Update to EM
Keywords: regression
Because Bug 296566 is not closed and all of the changes have not landed,
shouldn't this be resolved as a dupe of that bug?
Whiteboard: pending completion update UI from BenG, bug 296868
Severity: enhancement → normal
(In reply to comment #3)
> Because Bug 296566 is not closed and all of the changes have not landed,
> shouldn't this be resolved as a dupe of that bug?

No, I added the status whiteboard comment.
Let's just wait for Ben to finish the job.

Attached patch patch (obsolete) — Splinter Review
Benjamin - it looks like some of the software update changes stomped on a
couple of recent changes as well as had a couple of minor errors - this gets
update for the EM working again.
Assignee: nobody → moz_bugzilla
Status: UNCONFIRMED → ASSIGNED
Attachment #185763 - Flags: review?(benjamin)
Comment on attachment 185763 [details] [diff] [review]
patch

This fixed 'most' of the errors but I need to spend some qiality time with the
code first.
Attachment #185763 - Attachment is obsolete: true
Attachment #185763 - Flags: review?(benjamin)
This is WFM after the patch for bug 296578 landed. I suspect there are other
bugs with update but performing the steps in comment #0 are now WFM.
Status: ASSIGNED → RESOLVED
Closed: 15 years ago
Resolution: --- → WORKSFORME
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.