Make the junk filter select mail for archive purposes

RESOLVED DUPLICATE of bug 181866

Status

Thunderbird
General
--
enhancement
RESOLVED DUPLICATE of bug 181866
13 years ago
13 years ago

People

(Reporter: Ivar Snaaijer, Assigned: Scott MacGregor)

Tracking

(Depends on: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

The Thunderbird junk filter is very good at determining a spam from good mail,
giving verry little false hits (eigter positive or negative). 

While thinking about a way to automate the archiving of email I am concidering
to use a byasian filter to decide if i want to have an email archived or not.

Most of us have to deal with some data retention rules at work, and archiving
email is one of the may things you need to do. but very little people like to
sift throug their mail for this purpose. 

I am currently not sure if it would be enoug to use all mail with an high enoug
positive (non spam) vaule or there is need for a seperate byasian database. I
hope it is possible to use the already calculated 'spam factor' of an email as
this whould simplyfy implementation greatly.





Reproducible: Always

Steps to Reproduce:
1. Receive a company email that needs to be archived
2. Run the bayasian filter against it
3. because it has a high 'not spam' rating *copy* it unread to a seperate folder
4. do the same with outgoing mail
5. use some archiving tool to archive the mail (convert to pdf if you must) 



The main aim is to give thunderbird a better edge against other propriatary mail
tools and a great added benefit for business use. I have a good experience with
using thunderbird with our MS exchange server using imap, but still have to sift
throug my mailbox for archiving purposes. creating a filter does help, but I
still get unexpected emails, that have all the halmarks of an interesting mail,
but are not automatically stored.

On the server is an other tool that drags the emails from the archive folder (it
is a public folder, it has also mail from others of my group) and stores them in
a database as pdf.

Comment 1

13 years ago
Related to Core bug 168905 and/or Core bug 181866?
(Reporter)

Comment 2

13 years ago
Darn, and I thougt that i had something original, i need to search better. I
also think it is a dupe.

*** This bug has been marked as a duplicate of 181866 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Depends on: 168905
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.