Firefox crashes when file browsing a directory with a tar.bz2 file

RESOLVED INVALID

Status

Core Graveyard
GFX: Gtk
RESOLVED INVALID
13 years ago
10 years ago

People

(Reporter: Benjamin Bach, Unassigned)

Tracking

1.7 Branch
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050405 Firefox/1.0.4 (Ubuntu package 1.0.2)
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050405 Firefox/1.0.4 (Ubuntu package 1.0.2)

I'll try to make a more detailed summary of which files that make it crash..
currently I'm 100% shure that putting a tar.bz2 file on my desktop and then
browsing there makes FF crash.

Reproducible: Always

Steps to Reproduce:
1. Put tar.bz2 file in ~/Desktop
2. Think happy thoughts
3. Re-open all your URLs =)

Actual Results:  
FF crashes
(Reporter)

Comment 1

13 years ago
I can't make a clear description of it. Can't reproduce it in the "Download ->
Save As -> Browse" dialog and it doens't seem to be specificly tar.bz2 files
that makes it crash using the upload dialog.

Probably has something more to do with my Ubuntu install.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID

Comment 2

13 years ago
the next time you file a bug about an ubuntu package here, could you first
install symbols for your gecko derivative so that you can have a stack trace
(from gdb, not to be confused w/ an strace).
(Reporter)

Comment 3

13 years ago
This is anyways the message from command line when FF crashes:

(Gecko:9074): Pango-CRITICAL **: _pango_engine_shape_covers: assertion
`PANGO_IS_FONT (font)' failed

(Gecko:9074): GLib-GObject-CRITICAL **: g_object_ref: assertion `G_IS_OBJECT
(object)' failed

(Gecko:9074): Pango-CRITICAL **: _pango_engine_shape_shape: assertion
`PANGO_IS_FONT (font)' failed

Pango-ERROR **: file shape.c: line 75 (pango_shape): assertion failed:
(glyphs->num_glyphs > 0)
aborting...
Aborted



---

I'll have my bug reporting tools ready for the next time. Sorry so much!

Updated

13 years ago
Component: File Handling → GFX: Gtk
Product: Firefox → Core
Version: unspecified → 1.7 Branch
(Assignee)

Updated

10 years ago
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.