bad arc rendering in <path> on MacOS X with cairo SVG

RESOLVED WORKSFORME

Status

()

Core
SVG
--
minor
RESOLVED WORKSFORME
13 years ago
10 years ago

People

(Reporter: euthymenes, Unassigned)

Tracking

Trunk
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b2) Gecko/20050609 Firefox/1.0+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b2) Gecko/20050609 Firefox/1.0+

In the page http://euthymenes.free.fr/rvj.svg, there are artefacts on arcs. Arcs
are interupted by little white triangles. Arctefacts are presents : on Mac OS X
with cairo SVG on Firefox 1.1
Artefacts are absent on Windows with Firefox 1.1.
Artefacts are absent on MacOx X with Firefox 0.8 with LibArt. 

Reproducible: Always

Steps to Reproduce:
1. open url http://euthymenes.free.fr/rvj.svg with Firefox 1.1 on MAcOS X with
SVG with cairo
2.
3.

Actual Results:  
The page is rendered with artefacts on arcs

Expected Results:  
Correctly render the page without artefacts on arcs.

I suspect a cairo bug on MacOs X

Comment 1

13 years ago
-> Core: SVG
Assignee: nobody → general
Component: General → SVG
Product: Firefox → Core
QA Contact: general → ian
Summary: bad arc rendering in <path> on MacOS X with cairo SVG → bad arc rendering in <path> on MacOS X with cairo SVG
Version: unspecified → Trunk
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/
Is this still an issue?
(Reporter)

Comment 4

11 years ago
(In reply to comment #3)
> Is this still an issue?
> 

No longer an issue on my test page. It works on :
Firefox 2.0.0.3
Mac Os X 10.4.9
Intel Core 2 Duo
It is not the initial configuration for the bug. I have changed all my configuration since the bug.

Comment 5

10 years ago
Works for me on current OS-X nightly.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.