If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

FF 1.0.4 Crash on Children International [@ GetNearestContainingBlock]

RESOLVED DUPLICATE of bug 287981

Status

()

Firefox
General
--
major
RESOLVED DUPLICATE of bug 287981
13 years ago
13 years ago

People

(Reporter: James Drabb, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

Every access to the Children Iternational (non-profit charity) site causes FF
1.0.4 under WinXP SP 2 to crash.  I haven't tried it on my Fedora Core 2 box
yet. Go to the URL:
http://childreninternational1.etools.ncol.com/qry/ci_rp_childselect.taf?ETTBHST_SITE_NAME=ci-rp-georgenoory&ETTFMRS_BHGR_ID=283&ETTFMRS_BHST_ID=977&hostName=George%20Noory&_UserReference=6064DB67B308EDF842A8BEDE&_nc=f04fccd5109403a370ad8ac21daed149

This URL is on a 3rd party site that is sponsoring a Childrends drive
(http://www.coasttocoastam.com/).

The Page comes up just fine in IE SP 2 (though that doesn't mean much ; )),
however it causes FF 1.0.4 to crash _every_ time.


Reproducible: Always

Steps to Reproduce:
1. Go to the URL below:
2.
http://childreninternational1.etools.ncol.com/qry/ci_rp_childselect.taf?ETTBHST_SITE_NAME=ci-rp-georgenoory&ETTFMRS_BHGR_ID=283&ETTFMRS_BHST_ID=977&hostName=George%20Noory&_UserReference=6064DB67B308EDF842A8BEDE&_nc=f04fccd5109403a370ad8ac21daed149
3.

Actual Results:  
FF 1.0.4 crahed under Win XP SP 2

Expected Results:  
Display of page.

No additional ino other than go to this URL:
http://childreninternational1.etools.ncol.com/qry/ci_rp_childselect.taf?ETTBHST_SITE_NAME=ci-rp-georgenoory&ETTFMRS_BHGR_ID=283&ETTFMRS_BHST_ID=977&hostName=George%20Noory&_UserReference=6064DB67B308EDF842A8BEDE&_nc=f04fccd5109403a370ad8ac21daed149

Granted, the web "developers" at Children International SUCK, however, it should
not crash FF 1.0.4!
Summary: FF 1.0.4 Crash on Children Iternational → FF 1.0.4 Crash on Children International
WFM Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.8) Gecko/20050511
Firefox/1.0.4
WFM Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b2) Gecko/20050609
Firefox/1.0+ ID:2005060914

James, when firefox crashed did you submit any TalkbackID crash information? If
so, what talkback ID number was it? (You can find this by running
../firefox/components/talkback.exe and copy&pasting the ID(s). Thanks!)
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b2) Gecko/20050609
Firefox/1.0+ ID:2005060914

WFM
(Reporter)

Comment 3

13 years ago
The TalkbackID is: TB6538196M
Thanks for the TBID James. Could you please try running firefox in its safemode
(http://kb.mozillazine.org/Safe_mode) and seeing if the crashing still happens?

Also (if possible) could you try the firefox 1.1alpha Deer Park build, and see
if you still have the crash? It could be something that has been fixed already.
http://www.mozilla.org/projects/firefox/
If you're going to use the 1.1alpha, I'd use a new profile for the Deer Park
version (http://kb.mozillazine.org/Profile_Manager)
Summary: FF 1.0.4 Crash on Children International → FF 1.0.4 Crash on Children International [@ GetNearestContainingBlock]

Updated

13 years ago
Summary: FF 1.0.4 Crash on Children International [@ GetNearestContainingBlock] → FF 1.0.4 Crash on Children International [@ GetNearestContainingBlock]
Also, dupe of bug 194952?
(Reporter)

Comment 6

13 years ago
I killed my profile and re-added all my extensions one-by-one.  Here is a shot
of my extensions that I added, in order:

http://keeliegirl.dyndns.org/tmp/Extensions.png

After killing my profile, and re-adding the extension, I can not reproduce the
error.  The only thing I can think of is that it was some weird setting in an
extension that caused this error and not a Firefox 1.0.4 error.

Feel free to close out this bug!

Comment 7

13 years ago
Incident ID: 6538196
Stack Signature	GetNearestContainingBlock 69e1bc08
Product ID	Firefox10
Build ID	2005051112
Trigger Time	2005-06-09 16:15:58.0
Platform	Win32
Operating System	Windows NT 5.1 build 2600
Module	firefox.exe + (0027b48b)
URL visited	http://www.coasttocoastam.com/
User Comments	From http://www.coasttocoastam.com/ I clicked on the sponsord link
to: http://www.coasttocoastam.com/
Since Last Crash	10 sec
Total Uptime	633771 sec
Trigger Reason	Access violation
Source File, Line No.
d:/builds/tinderbox/Fx-Aviary1.0.1/WINNT_5.0_Depend/mozilla/layout/html/base/src/nsHTMLReflowState.cpp,
line 563
Stack Trace 	
GetNearestContainingBlock 
[d:/builds/tinderbox/Fx-Aviary1.0.1/WINNT_5.0_Depend/mozilla/layout/html/base/src/nsHTMLReflowState.cpp,
line 563]
nsHTMLReflowState::InitAbsoluteConstraints 
[d:/builds/tinderbox/Fx-Aviary1.0.1/WINNT_5.0_Depend/mozilla/layout/html/base/src/nsHTMLReflowState.cpp,
line 947]
nsHTMLReflowState::InitConstraints 
[d:/builds/tinderbox/Fx-Aviary1.0.1/WINNT_5.0_Depend/mozilla/layout/html/base/src/nsHTMLReflowState.cpp,
line 1846]
nsHTMLReflowState::Init 
[d:/builds/tinderbox/Fx-Aviary1.0.1/WINNT_5.0_Depend/mozilla/layout/html/base/src/nsHTMLReflowState.cpp,
line 336]
nsHTMLReflowState::nsHTMLReflowState 
[d:/builds/tinderbox/Fx-Aviary1.0.1/WINNT_5.0_Depend/mozilla/layout/html/base/src/nsHTMLReflowState.cpp,
line 309]
nsAbsoluteContainingBlock::ReflowAbsoluteFrame 
[d:/builds/tinderbox/Fx-Aviary1.0.1/WINNT_5.0_Depend/mozilla/layout/html/base/src/nsAbsoluteContainingBlock.cpp,
line 424]
nsAbsoluteContainingBlock::IncrementalReflow 
[d:/builds/tinderbox/Fx-Aviary1.0.1/WINNT_5.0_Depend/mozilla/layout/html/base/src/nsAbsoluteContainingBlock.cpp,
line 287]
nsBlockFrame::Reflow 
[d:/builds/tinderbox/Fx-Aviary1.0.1/WINNT_5.0_Depend/mozilla/layout/html/base/src/nsBlockFrame.cpp,
line 638]
nsContainerFrame::ReflowChild 
[d:/builds/tinderbox/Fx-Aviary1.0.1/WINNT_5.0_Depend/mozilla/layout/html/base/src/nsContainerFrame.cpp,
line 982]
CanvasFrame::Reflow 
[d:/builds/tinderbox/Fx-Aviary1.0.1/WINNT_5.0_Depend/mozilla/layout/html/base/src/nsHTMLFrame.cpp,
line 554]
nsBoxToBlockAdaptor::Reflow 
[d:/builds/tinderbox/Fx-Aviary1.0.1/WINNT_5.0_Depend/mozilla/layout/xul/base/src/nsBoxToBlockAdaptor.cpp,
line 884]
nsBoxToBlockAdaptor::DoLayout 
[d:/builds/tinderbox/Fx-Aviary1.0.1/WINNT_5.0_Depend/mozilla/layout/xul/base/src/nsBoxToBlockAdaptor.cpp,
line 626]
nsBox::Layout 
[d:/builds/tinderbox/Fx-Aviary1.0.1/WINNT_5.0_Depend/mozilla/layout/xul/base/src/nsBox.cpp,
line 1016]
nsBox::Layout 
[d:/builds/tinderbox/Fx-Aviary1.0.1/WINNT_5.0_Depend/mozilla/layout/xul/base/src/nsBox.cpp,
line 1016]
nsGfxScrollFrameInner::LayoutBox 
[d:/builds/tinderbox/Fx-Aviary1.0.1/WINNT_5.0_Depend/mozilla/layout/html/base/src/nsGfxScrollFrame.cpp,
line 1264]
nsGfxScrollFrame::DoLayout 
[d:/builds/tinderbox/Fx-Aviary1.0.1/WINNT_5.0_Depend/mozilla/layout/html/base/src/nsGfxScrollFrame.cpp,
line 1273]
nsBox::Layout 
[d:/builds/tinderbox/Fx-Aviary1.0.1/WINNT_5.0_Depend/mozilla/layout/xul/base/src/nsBox.cpp,
line 1016]
nsGfxScrollFrame::Reflow 
[d:/builds/tinderbox/Fx-Aviary1.0.1/WINNT_5.0_Depend/mozilla/layout/html/base/src/nsGfxScrollFrame.cpp,
line 873]
nsContainerFrame::ReflowChild 
[d:/builds/tinderbox/Fx-Aviary1.0.1/WINNT_5.0_Depend/mozilla/layout/html/base/src/nsContainerFrame.cpp,
line 982]
ViewportFrame::Reflow 
[d:/builds/tinderbox/Fx-Aviary1.0.1/WINNT_5.0_Depend/mozilla/layout/html/base/src/nsViewportFrame.cpp,
line 249]
IncrementalReflow::Dispatch 
[d:/builds/tinderbox/Fx-Aviary1.0.1/WINNT_5.0_Depend/mozilla/layout/html/base/src/nsPresShell.cpp,
line 904]
PresShell::ProcessReflowCommands 
[d:/builds/tinderbox/Fx-Aviary1.0.1/WINNT_5.0_Depend/mozilla/layout/html/base/src/nsPresShell.cpp,
line 6401]
ReflowEvent::HandleEvent 
[d:/builds/tinderbox/Fx-Aviary1.0.1/WINNT_5.0_Depend/mozilla/layout/html/base/src/nsPresShell.cpp,
line 6226]
PL_HandleEvent 
[d:/builds/tinderbox/Fx-Aviary1.0.1/WINNT_5.0_Depend/mozilla/xpcom/threads/plevent.c,
line 674]
0x778b0c24
NS_Get3DColors 
[d:/builds/tinderbox/Fx-Aviary1.0.1/WINNT_5.0_Depend/mozilla/layout/html/style/src/nsCSSColorUtils.cpp,
line 102]
0x0b75008a


*** This bug has been marked as a duplicate of 287981 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.