email address completion overrides full email address typed if I pause during typing

VERIFIED DUPLICATE of bug 278398

Status

Thunderbird
Message Compose Window
--
major
VERIFIED DUPLICATE of bug 278398
13 years ago
13 years ago

People

(Reporter: raylau1234, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; iOpus-I-M; SV1; .NET CLR 1.1.4322)
Build Identifier: 

If I am entering an email address that is not in my address book, but type too 
slowly (i.e., pause), and then hit enter, it uses a proposed match from my 
address book instead of the email address I typed in.

This is sinister bec. it has often resulted in misdirected email going to 
people in my address book.

Reproducible: Always

Steps to Reproduce:
1. Assuming your address book does not have any users with names like "hello" 
and you have email address completion turned on from local address books.

2. Create a new address book entry

First name: hello
Last name: world
email: helloworld@foo.com

3.Ctrl M to compose a new msg.

4. In the 1st To: box, type "hello".  Then pause...  helloworld@foo.com will 
flash.

5. Now continue typing QUICKLY "@bar.com<enter>".  (If you type slowly, it 
will work.)

Actual Results:  
The first To: box has the address from the address book helloworld@foo.com.

Expected Results:  
It should have the address I typed hello@bar.com

This happens with 1.0.2 on both my desktop (faster CPU) and laptop.  I am 
proposing this as Major bec. in my experience, I've run into about 1-2 
misdirected emails as a result....
(Reporter)

Comment 1

13 years ago
That's 1-2 misdirected emails per wk.

Comment 2

13 years ago
This sounds like bug 278398.  Reporter, if you agree, please mark this bug as a 
dupe of that one.
(Reporter)

Comment 3

13 years ago
The very end of 278398 does sounds like the same thing... CR vs TAB is 
probably a trivial difference.  Marking as dupe.

*** This bug has been marked as a duplicate of 278398 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE

Updated

13 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.