Tools -> DOM Inspector opens empty; Ctrl+Shift+I works fine

RESOLVED FIXED

Status

()

Firefox
Menus
RESOLVED FIXED
13 years ago
13 years ago

People

(Reporter: Peter6, Assigned: Steffen Wilberg)

Tracking

({regression})

Trunk
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

1.03 KB, patch
Benjamin Smedberg
: review+
Benjamin Smedberg
: approval-aviary1.1a2+
Details | Diff | Splinter Review
(Reporter)

Description

13 years ago
repro:

go to Menu -> Tools -> Dom Inspector   Ctrl+Shift+i
and press the link.

result :

Domi opens empty , the current url is not in the "inspect" bar

When Ctrl+Shift+i is pressed DomI opens with the current page

Comment 1

13 years ago
Selecting Tools->DOM Inspector should open up with the current URL content, just
as Shift-Ctrl-I does.

Comment 2

13 years ago
Confirming on Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2)
Gecko/20050608 Firefox/1.0+
(Reporter)

Comment 3

13 years ago
how about a menu change to:

Tools
----
----
----
Dom Inspector > Inspect the current page (ctrl+shift+i) /(cmd+shift+i)
                Inspect Chrome
----
----

to keep everyone happy ?
Damn, I missed that in the review.  And this is actually a good thing for my
daily work since I don't use the page bits much, but its a UI change that we
shouldn't make, since its targeted as a web developer tool, primarily (chrome is
a neat bonus, but we want to be pushing this for web devs and this hinders that
too much).

http://lxr.mozilla.org/mozilla/source/extensions/inspector/resources/content/tasksOverlay-ff.xul#40
needs to changed to use Tasks:InspectPage.  I don't think this is expected, and
even so, the listed shortcut does it, so that's totally broken.

This is so not going the submenu route, I think we need a chromedev extension
that adds some extra bits to make it easier to debug chrome, but this shouldn't
be a default-ship option.  Its more of a "500 or so users might want this
option" deal.
(Reporter)

Comment 5

13 years ago
*** Bug 296621 has been marked as a duplicate of this bug. ***
There's also a big grey blank area at the bottom of the DOM Inspector window
with a little caret ^ symbol, suggesting there's an XML error somewhere. 
(Reporter)

Comment 7

13 years ago
(In reply to comment #6)
> There's also a big grey blank area at the bottom of the DOM Inspector window
> with a little caret ^ symbol, suggesting there's an XML error somewhere.
looks normal here (thin line) for both chrome/url inspection
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b2) Gecko/20050613
Firefox/1.0+ ID:2005061308

Comment 8

13 years ago
I see the red arrow too, "Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US;
rv:1.8b2) Gecko/20050613 Firefox/1.0+", standard build options.
(Assignee)

Comment 9

13 years ago
Created attachment 186643 [details] [diff] [review]
patch

As explained in comment 4.
Assignee: nobody → steffen.wilberg
Status: NEW → ASSIGNED
Attachment #186643 - Flags: review?(mconnor)
(Assignee)

Updated

13 years ago
Keywords: regression
OS: Windows 2000 → All
Hardware: PC → All
Summary: Menu , Dom Inspector opens empty → Tools -> DOM Inspector opens empty; Ctrl+Shift+I works fine
Flags: blocking-aviary1.1?

Comment 10

13 years ago
Comment on attachment 186643 [details] [diff] [review]
patch

r+a=me
Attachment #186643 - Flags: review?(mconnor)
Attachment #186643 - Flags: review+
Attachment #186643 - Flags: approval-aviary1.1a2+
(Assignee)

Comment 11

13 years ago
Checking in mozilla/extensions/inspector/resources/content/tasksOverlay-ff.xul;
/cvsroot/mozilla/extensions/inspector/resources/content/tasksOverlay-ff.xul,v 
<--  tasksOverlay-ff.xul
new revision: 1.2; previous revision: 1.1
done

Regarding comments 6 and 8, I haven't seen this. Marking fixed.
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago
Flags: blocking-aviary1.1?
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.