Camino takes up more memory than FireFox?

RESOLVED INVALID

Status

--
enhancement
RESOLVED INVALID
14 years ago
14 years ago

People

(Reporter: starfirex, Assigned: mikepinkerton)

Tracking

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b2) Gecko/20050609 Camino/0.9a1
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b2) Gecko/20050609 Camino/0.9a1

Considering that Firefox uses a custom skin engine and is generally larger,
FireFox takes anywhere from 3 to 10MB of physical and 35-100MB of virtual less
memory than Camino. I consider this a bug. Also, I've just noticed that the text
insertion point does some crazy blinking **** when you type in a text field.
Kind of annoying.

Reproducible: Always
I assume you're talking about a specific webpage that takes that much memory?
Becaues Camino doesn't use more RAM than Firefox unless the site(s) use a lot of
plugins.

Please specify what you want this bug to be about or it will be marked as INVALID.
(Reporter)

Comment 2

14 years ago
I'll do a simple test, I'll load three of the same pages in tabs with both
applications, then get the stats from activity monitor on both.

Results:
With 1GHz eMac, 1GB RAM 60GB HD. This page, http://starfire.cyanide-x.com and
http://www.blizzard.com loaded in tabs for both applications.
Camino- Physical RAM: ~38MB  VMem: ~177MB  CPU: 8-9%
FireFox- Physical RAM: ~40MB VMem: ~340MB CPU: 6-7%

The results changed a bit while I was taking the data down, but I accounted for
it as best as I could. The results now are interesting. The previous test I did
may have been skewed by the fact that I had a lot of programs open (including
photoshop and imageready). Interestingly, Camino has consistently higher CPU
usage, going as high as 9.5% when idle, while firefox will not go over 7%.
Another quick test shows that is also has slightly higher cpu usage when
refreshing a page(23% vs 20%). Not sure what to make of it, but the text boxes
still do the funny blinking thing when you type ;P.
I'm almost positive that everything you're experiencing is related to plugins
(Flash, Real, Java, etc) and are filed in their respective bugs (form bugs also
plague Camino, but have been filed). In addition, Camino make take more CPU
simply because it's interacting with the OS more. Nothing to be worried about.

This bug is covered in other bugs, making INVALID. Please open a new bug if you
find a specific cause for high memory/CPU usage.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.