first tab content moving up/down when opening/closing second tab in background

RESOLVED DUPLICATE of bug 246186

Status

()

--
trivial
RESOLVED DUPLICATE of bug 246186
14 years ago
14 years ago

People

(Reporter: harald.langhammer, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de-DE; rv:1.8b2) Gecko/20050610 Firefox/1.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050610 Firefox/1.0+

If you have tab bar always visible and open a second tab in background the
content of the first tab moves down some pixels. When closing the second tab the
content moves up again. Does not happen again when opening a third, fourth ...
tab. So there is a difference in layout between state "only one tab" and state
"two ore more tabs".

Reproducible: Always

Steps to Reproduce:
1. set browser.tabs.autohide to true
2. open a page with links
3. click on a link with middle mouse
4. close second tab by middle mouse click on the tab

Actual Results:  
after 3. the content of the first tab moves a little down, after 4. the content
moves up again.

Expected Results:  
content of the first tab should not move when opening a second tab.

It seems to be only a "cosmetic" problem but if you use Firefox via a remote
connection like terminal server, remote desktop or VNC over a slower connection
the movement causes an annoying and unnecessary transfer of the moved screen
content.
Of course this problem is not seen when browser.tabs.autohide is set to false
but then there is much more (intended) movement which I want to avoid by always
showing the tab bar.

Comment 1

14 years ago

*** This bug has been marked as a duplicate of 246186 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.