Can not exec whois to a Chinese nick sometime.

RESOLVED FIXED

Status

RESOLVED FIXED
14 years ago
13 years ago

People

(Reporter: steekid, Assigned: rginda)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [cz-0.9.69], URL)

Attachments

(1 attachment)

738 bytes, patch
bugzilla-mozilla-20000923
: review+
Details | Diff | Splinter Review
(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; zh-CN; rv:1.7.8) Gecko/20050511 Firefox/1.0.4 (ax)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; zh-CN; rv:1.7.8) Gecko/20050511 Firefox/1.0.4 (ax)

When somebody with Chinese nick start a private chat window and send message to
me, my chatzilla should exec whois to him. But it return "No such nick xxx". The
xxx is his nick but it is unreadable.

Reproducible: Always

Steps to Reproduce:
1.Startup chatzilla
2./server chat.webking.cn
3.Request somebody with Chinese nick open a private chat window to you and send
some message.
Actual Results:  
You will got "No such nick xxx".xxx is unreadable.


Expected Results:  
The software should return WHOIS infomation.

I think it can not deal with Chinese character correctly at this time.

Comment 1

14 years ago
Reporter, could you please state which version of ChatZilla you're using?
Also, does this problem occur on any other servers?
Last but not least: you say this occurs 'sometimes' - could you try to find out
what kinds of nicks make it fail?
Thanks :-).
(Reporter)

Comment 2

14 years ago
(In reply to comment #1)
> Reporter, could you please state which version of ChatZilla you're using?
> Also, does this problem occur on any other servers?
> Last but not least: you say this occurs 'sometimes' - could you try to find out
> what kinds of nicks make it fail?
> Thanks :-).

Version: Chatzilla 0.9.68a [Firefox 1.0.4/20050511]
My charset is GB2312.
I had a try on another server irc.263.net. It occured again. I think when the
nick include any Chinese or other multi-byte character, this problem will occur.
By the way, when I open a private chat window to somebody on my own initiative,
my client will query WHOIS information about him too. If his nick includes
Chinese character, I will got " NO nick give". If his nick only include
single-byte character, I will got WHOIS information correctly.
If I right-click the nick including Chinese character in the user list in a
channel room window and select "who is" item, it will reply WHOIS information
correctly.
If I change to another client mIRC, the all problems above will disappear. So I
think it relates to Chatzilla itself.

Comment 3

14 years ago
Created attachment 186009 [details] [diff] [review]
Patch

CIRCServer.prototype.whois does a fromUnicode on what we pass in. That'd make
me assume that we should pass in something that is actually unicode, because I
can imagine things get a bit messed up if it isn't :-).

R? = samuel (or anyone who has the time)

Reporter, if you know how to work with patches, feel free to test this out. I
don't have Chinese fonts installed on my system, and don't use nicknames with
double-byte characters in them, so I don't have any real way to test this out.
If you do not know how to handle patches, feel free to mention it on the bug or
send me an email, and I'll attach an xpi here or mail it to you directly :-).

(Also note that the latest ChatZilla version is 0.9.68.5 :-) )
Attachment #186009 - Flags: review?(samuel)

Comment 4

14 years ago
Comment on attachment 186009 [details] [diff] [review]
Patch

r=silver
Attachment #186009 - Flags: review?(samuel) → review+

Updated

14 years ago
Attachment #186009 - Flags: approval1.8b3?

Updated

14 years ago
Attachment #186009 - Flags: approval1.8b3? → approval1.8b3+

Comment 5

14 years ago
Checked in -> FIXED.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
Whiteboard: [cz-0.9.68.6]

Updated

13 years ago
Whiteboard: [cz-0.9.68.6] → [cz-0.9.69]
You need to log in before you can comment on or make changes to this bug.