Addons remain in queue after authors have deleted their accounts

VERIFIED DUPLICATE of bug 324671

Status

addons.mozilla.org Graveyard
Developer Pages
--
major
VERIFIED DUPLICATE of bug 324671
13 years ago
2 years ago

People

(Reporter: alanjstr, Assigned: alanjstr)

Tracking

Details

Attachments

(1 attachment, 2 obsolete attachments)

7.31 KB, patch
Chris Thomas (CTho) [formerly cst@andrew.cmu.edu cst@yecc.com]
: first-review+
Details | Diff | Splinter Review
(Assignee)

Description

13 years ago
SMSalias MozClient 1.0.2 is still in the review queue but the author has deleted
his account.
(Assignee)

Comment 1

13 years ago
Created attachment 186001 [details] [diff] [review]
Make sure authors are set
Attachment #186001 - Flags: first-review?(cst)
(Assignee)

Updated

13 years ago
Status: NEW → ASSIGNED
Target Milestone: 1.0 → 1.1
Comment on attachment 186001 [details] [diff] [review]
Make sure authors are set

Please use more lines of context when creating diffs.

I'd rather delete the extensions or something when the account goes away than
leave stuff effectively as orphans just sitting in the db.
(Assignee)

Comment 3

13 years ago
(In reply to comment #2)
> I'd rather delete the extensions or something when the account goes away than
> leave stuff effectively as orphans just sitting in the db.

Well, that can happen for UMO 2.0, however they shouldn't be getting orphaned in
the first place.  
(Assignee)

Comment 4

13 years ago
Created attachment 186032 [details] [diff] [review]
Purge from Main, too
Attachment #186001 - Attachment is obsolete: true
Attachment #186032 - Flags: first-review?(cst)
Attachment #186032 - Flags: first-review?(cst) → first-review+
Comment on attachment 186032 [details] [diff] [review]
Purge from Main, too

delete the authorxref entry too.
Attachment #186032 - Flags: first-review+ → first-review-
(Assignee)

Comment 6

13 years ago
Created attachment 186063 [details] [diff] [review]
Purge from all tables

This also takes care of a few quoting errors that appear when you have it show
all errors
Attachment #186032 - Attachment is obsolete: true
Attachment #186063 - Flags: first-review?(cst)
Attachment #186063 - Flags: first-review?(cst) → first-review+

*** This bug has been marked as a duplicate of 324671 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE

Updated

12 years ago
Status: RESOLVED → VERIFIED
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.