Cannot send large attachment "SMTP server error" caused by AVAST virus checker

RESOLVED INCOMPLETE

Status

Plugins Graveyard
Avast AV
--
major
RESOLVED INCOMPLETE
13 years ago
2 years ago

People

(Reporter: Marc Croteau, Unassigned)

Tracking

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050531 Firefox/1.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050531 Firefox/1.0+

When I compose an email with a "large" attachment, Thunderbird tries to send the
message but fails with an "SMTP server error". Tried with 2 different SMTP servers.

Doing the same with Thunderbird 1.0.2 works fine.

Reproducible: Always

Steps to Reproduce:
1. Prepare a large attachment or multiple smaller attachments (tested with
multiple JPEG images and a ZIP (> 1MB) containing the images
2. Compose a new message and attach the prepared attachment
3 [review]. Hit [Send]
4. Wait until Thunderbird finishes uploading the attachment to the SMTP server

Actual Results:  
*** You receive an error message ***

Expected Results:  
Message and attachment should be transfered correctly

Comment 1

13 years ago
Mozilla Thunderbird 1.1 Alpha 1 (20050531)

I just tried this by sending myself two pictures totalling 1.29 MB to my SMTP
server.  This worked correctly without errors and I received them correctly as
well.  This test was performed on my university SMTP server and my home ISP
server.  Both worked correctly.

Do you know if your email servive allows for attachments and messages larger
than 1 MB?  Some don't let you send emails if they are over a certain size.
(Reporter)

Comment 2

13 years ago
(In reply to comment #1)
> Mozilla Thunderbird 1.1 Alpha 1 (20050531)
> 
Both SMTP servers I tested this on allow large attachments. As I state in the
original report, reverting to Thunderbird 1.0.2 lets them through !

My settings are as follows:

Forward: Inline

Compose Format: HTTP

Send: Both as HTTP and Plain Text

Comment 3

13 years ago
Keep in mind that I can't reproduce this, so I'm not actually sure what could be
causing the problem.

Double-check that the new version of Thunderbird has the correct settings for
your servers.  If the error gives anything more specific besides "SMTP server
error", could you please post that here to help narrow down this problem. If you
happen to have a lot of time, you could try sending files with different sizes
to see what the threshold is.  Maybe that value will be able to help with this.

If nothing seems to work, try creating a new profile in the new version of
Thunderbird and see if that solves it.  You may have a setting in your
preferences that is messing everything up. Instructions for doing this if you
aren't sure can be found at http://www.mozilla.org/support/thunderbird/profile
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/
I would like to confirm this bug as I already did with bug N° 280475

I can reproduce this bug exactly the same way.
The same msseage with no attachements is sent correctly.
The size of the file attached seeems to have an effect on the issue.
If the attachement is approximatively grater than 200ko mail is not sent.

This bug is very critical.
I use smtp.wanadoo.fr server.
I have contacted wanadoo, and they do not notice anything rong.
My internet connection is quite slow, 64k and it might be only a broblem du to
time out.
But there are no time out options to set on the accounts.

I would like to confirm this bug but dont know how to do ...

Comment 6

13 years ago
This is most likely a virus checker getting in the way, slowing things down,
until we timeout. If you are running tbird 1.5beta1 or b2, do tools | options |
advanced and edit the connection timeout value. If that doesn't help, then it's
likely the virus checker is completely stopping the sending process, in which
case, you could try disabling it to verify it's a virus checker.

Comment 7

12 years ago
I have the same problem. This is definitely caused by antivirus software (avast! in my case). When I turn off it it works ok. But how to send messages without turning off avast? Changing timeout in Tools > Advanced > timeout didn't help in my case. 
It seems that avast! is "capturing" the connection and tbird sees the message is being sent, but it's probably just copied to avast's buffer where it's checked for viruses and evantually sent. But the time the message is checked and sent may be long and it probably seems dead to tbird (no bytes sent nor received hence there is no point in keeping this connection alive?). 
(Reporter)

Comment 8

12 years ago
After many months of sending messages without any problems, I confirm this bug is due to my antivirus (AVAST).

Disabling the antivirus no longer reproduces this problem.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED

Comment 9

12 years ago
Marc, the correct resolution is INVALID, because this is not a TB/mozilla problem.
resolution FIXED is used for bugs that have an verified patch.
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---
Summary: Cannot send large attachment → Cannot send large attachment "SMTP server error" caused by AVAST virus checker

Updated

12 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago12 years ago
Resolution: --- → INVALID

Updated

11 years ago
Duplicate of this bug: 317224

Comment 11

7 years ago
We're now tracking such bugs. This doesn't mean it's something we can fix, merely something we hope to be able to point vendors to so they can investigate. This is an automated message.
Assignee: mscott → nobody
Status: RESOLVED → UNCONFIRMED
Component: Message Compose Window → Avast AV
Product: Thunderbird → Plugins
QA Contact: avast-antivirus
Resolution: INVALID → ---

Comment 12

2 years ago
Closing old bugs in the Plugins component. We aren't going to track issues in 3rd-party plugins in the Mozilla bug tracker. In addition, support for NPAPI plugins will be removed at the end of this year; for more details see the post at https://blog.mozilla.org/futurereleases/2015/10/08/npapi-plugins-in-firefox/

If there is a serious bug in Firefox, it needs to be filed in the "Core" product, "Plug-Ins" component.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago2 years ago
Resolution: --- → INCOMPLETE
(Assignee)

Updated

2 years ago
Product: Plugins → Plugins Graveyard
You need to log in before you can comment on or make changes to this bug.