Closed Bug 297549 Opened 15 years ago Closed 13 years ago

When changing number of results in LDAP search, the new number does not take effect until Thunderbird is restarted

Categories

(MailNews Core :: LDAP Integration, defect, minor)

defect
Not set
minor

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: licensing, Assigned: standard8)

References

Details

User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en) AppleWebKit/412 (KHTML, like Gecko) Safari/412
Build Identifier: Thunderbird version 1.0.2 (20050317)

The default number of returns in an LDAP search is 100 (found under Advanced tab).  When you try to 
change this number, you have to restart Thunderbird for the new setting to take effect.

Reproducible: Always

Steps to Reproduce:
1. Configure LDAP
2. Click on Address Book
3. Choose your LDAP directory in left pane and double click it.
4. Click on Advanced Tab
5. Change 100 to 500 (or other number) for the "Don't return more than _______ results" field.  
6. Restart Thunderbird for settings to take effect.

Actual Results:  
LDAP search works perfectly.

Expected Results:  
The new LDAP setting should have been retained without restarting the app.
Confirming with Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a1) Gecko/20050926
SeaMonkey/1.1a

and moving to Core.

Note that bug 124553 may be related, but we don't know the code paths at the
moment to be sure.
Status: UNCONFIRMED → NEW
Component: Address Book → MailNews: LDAP Integration
Ever confirmed: true
OS: MacOS X → All
Product: Thunderbird → Core
Hardware: Macintosh → All
Version: unspecified → Trunk
Duplicate of this bug: 325314
Depends on: 124553
Assignee: mscott → bugzilla
This is fixed by the patch on bug 124553 that I just checked in.
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.