Closed Bug 297608 Opened 17 years ago Closed 17 years ago

Adding product causes null value in not null column error using PostgreSQL

Categories

(Bugzilla :: Administration, task)

2.19.3
x86
Linux
task
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 296039

People

(Reporter: dkl, Unassigned)

Details

Adding a new product using latest CVS HEAD on PostgreSQL database causes a blank
page with a SQL error in error_log:

[Mon Jun 13 21:13:17 2005] [error] [client 172.16.48.200] DBD::Pg::st execute
failed: ERROR:  null value in column "sortkey" violates not-null constraint,
referer: https://bugzilla.redhat.com/mozilla-tip/editproducts.cgi?action=add
[Mon Jun 13 21:13:17 2005] [error] [client 172.16.48.200]  [for Statement
"INSERT INTO milestones (product_id, value) VALUES (3, '---')"] at
Bugzilla/DB.pm line 80, referer:
https://bugzilla.redhat.com/mozilla-tip/editproducts.cgi?action=add
[Mon Jun 13 21:13:17 2005] [error] [client 172.16.48.200]
!Bugzilla::DB::SendSQL('INSERT INTO milestones (product_id, value) VALUES (3,
\'---\')') called at /var/www/bugzilla/mozilla-tip/editproducts.cgi line 511,
referer: https://bugzilla.redhat.com/mozilla-tip/editproducts.cgi?action=add

Maybe adding a 0 to the INSERT's for sortkey or removing NOT NULL constraint
will solve this. Removing NOT NULL is probably less preferrable to just putting
a 0 in the column by default for new product which will only have a single
milestone initially.

*** This bug has been marked as a duplicate of 296039 ***
Status: NEW → RESOLVED
Closed: 17 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.