Specifying width and height in pixels doesn't permit Flash movie to fit browser window

RESOLVED DUPLICATE of bug 264474

Status

()

RESOLVED DUPLICATE of bug 264474
14 years ago
14 years ago

People

(Reporter: martin.monroe, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; YPC 3.0.3; SV1; .NET CLR 1.1.4322; yplus 4.1.00b)
Build Identifier: Firefox 1.0.4

This bug report is similar to several previous reports. 264474 is a good 
example. I didn't find a satsifactory response in any of the bug reports.
1. In publishing a Flash movie, specifying the width and height as 100% 
permits the movie to scale to fit the browser window. This is handy because 
the movie scales to match different monitor sizes. However, while IE is 
acpable of doing this, Firefox isn't. In fact, my movie shows up as a very 
small square in the upper part of the screen when I specify the width and 
height as 100%.
2. When I read through the responses to this bug, people seemed to be 
concluding that specifying the width and height in pixels solves the problem. 
Yes, this does increase the size of my movie but it doesn't allow the movie to 
scale depending upon which monitor size the user has. So specifying the width 
and height defeats the whole purpose of being able to scvale the movie to 
different monitor sizes. 
3. Unless I have totally misunderstood the previous bug reports, is Firefox 
going to be fixed so that I can use the width and height = 100% option that 
Macromedia Flash provides or must I revert to a less desirable strategy such 
as specifying the width and height in pixels?

Martin Monroe 

Reproducible: Always

Steps to Reproduce:
1. Open the web site in Firefox
2.
3.

Actual Results:  
The movie shows up as a very small square in the upper portion of the screen

Expected Results:  
The movie should "scale" to match the browser window.
and why Do you file it again if there is already a bug report ?


*** This bug has been marked as a duplicate of 264474 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.