"Send Link" context menu should be renamed to "E-mail Link..." as it's confusing for Windows users

RESOLVED WONTFIX

Status

()

Firefox
Menus
--
trivial
RESOLVED WONTFIX
13 years ago
12 years ago

People

(Reporter: Robert Rothenberg, Assigned: u88484)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

11.97 KB, patch
beltzner
: review-
Details | Diff | Splinter Review
(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

Windows has context menus for folders and files to "Send to" an application
(such as E-mail, file, or a special folder).

Windows users will expect the "Send Link..." (and corresponding "Send Image...")
context menu items to have the same functionality.

Reproducible: Always

Steps to Reproduce:

Comment 1

13 years ago
This should be marked as Severity: enhancement.
(Assignee)

Comment 2

13 years ago
Created attachment 194918 [details] [diff] [review]
patch

patch if we want to change this
Attachment #194918 - Flags: review?(mike)
(Assignee)

Comment 3

13 years ago
Created attachment 197860 [details] [diff] [review]
patch v2

Final patch if we actually do want this for after 1.5.
Filed Bug# 310457 for changing 'Send Image...' to 'Email Image...'
Assignee: nobody → supernova_00
Attachment #194918 - Attachment is obsolete: true
Status: UNCONFIRMED → ASSIGNED
Attachment #197860 - Flags: review?(beltzner)
(Assignee)

Updated

13 years ago
Attachment #194918 - Flags: review?(beltzner)
*** Bug 321502 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

12 years ago
Keywords: uiwanted
(removing uiwanted)
Keywords: uiwanted
I disagree that this would be confusing to Windows users, as the item isn't "Send to..." it's "Send Image...". In the future we actually want to be able to add different ways of sending that image/resource (ie: webmail, IM, flickr, some other service) and I think that switching the label to "E-Mail" pens us in and doesn't really add a lot in the way of usability.
Status: ASSIGNED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WONTFIX
Attachment #197860 - Flags: review?(beltzner) → review-
You need to log in before you can comment on or make changes to this bug.