javascript strict warning in customizeToolbar.xul

VERIFIED FIXED in Firefox 2

Status

()

Firefox
Toolbars and Customization
--
trivial
VERIFIED FIXED
13 years ago
12 years ago

People

(Reporter: Romain BEZUT, Assigned: whimboo)

Tracking

(Blocks: 1 bug)

Trunk
Firefox 2
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 2 obsolete attachments)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050613 Firefox/1.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050613 Firefox/1.0+

It happens when you move an item from a "Customize Toolbar" window, i found two
of them :
The first : open JavaScript Console then do a right click on a Toolbar,
customize... and try to move an item, it makes a JS strict warning (if they have
been enabled).

The second : open JavaScript Console then go to Help Menu, Help Contents, click
on the 5th icon in order to "customize" and try to move an item, it makes a JS
strict warning, located in an other file than above.

Reproducible: Always

Steps to Reproduce:
see details
Actual Results:  
A JS strict warning.

Expected Results:  
The JS strict warnings are corrected.
(Reporter)

Comment 1

13 years ago
Created attachment 186196 [details] [diff] [review]
patch
Attachment #186196 - Flags: review?(mconnor)
Status: UNCONFIRMED → NEW
Ever confirmed: true
Please mark all javascript strict warning bugs as blocking bug 296661.
(Assignee)

Updated

13 years ago
Attachment #186196 - Flags: review?(mconnor) → review?(benjamin)
(Reporter)

Updated

13 years ago
Assignee: nobody → r.bezut

Comment 3

13 years ago
Comment on attachment 186196 [details] [diff] [review]
patch

Whatever this gDraggingFromPalette variable was supposed to be is now dead.
Please remove it entirely and re-request review from mconnor.
Attachment #186196 - Flags: review?(benjamin) → review-
(Reporter)

Updated

13 years ago
Attachment #186196 - Attachment is obsolete: true
(Reporter)

Comment 4

13 years ago
Created attachment 186461 [details] [diff] [review]
patch v2
Attachment #186461 - Flags: review?(mconnor)
Comment on attachment 186461 [details] [diff] [review]
patch v2

please ignore the one in help, since that entire file is going away rsn.

Please fix all other instances of this, including calendar/mail/composer
Attachment #186461 - Flags: review?(mconnor) → review-
(Assignee)

Comment 6

13 years ago
Created attachment 196461 [details] [diff] [review]
Final patch

Final patch includes fixes for calendar, composer, mail, and toolkit.
Assignee: r.bezut → hskupin
Attachment #186461 - Attachment is obsolete: true
Status: NEW → ASSIGNED
Attachment #196461 - Flags: review?(mconnor)
Comment on attachment 196461 [details] [diff] [review]
Final patch

that'll do, not needed for branch, its just a warning
Attachment #196461 - Flags: review?(mconnor) → review+
(Assignee)

Updated

13 years ago
Whiteboard: [checkin needed]
Trunk:
mozilla/calendar/sunbird/base/content/customizeToolbar.xul; new revision: 1.3;
mozilla/composer/base/content/customizeToolbar.xul; new revision: 1.2;
mozilla/mail/base/content/customizeToolbar.xul; new revision: 1.10;
mozilla/toolkit/content/customizeToolbar.xul; new revision: 1.14;
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
Whiteboard: [checkin needed]
Target Milestone: --- → Firefox1.6-
Version: unspecified → Trunk
(Assignee)

Updated

13 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.