Background color not displayed on for index watch table

VERIFIED DUPLICATE of bug 7656

Status

()

P2
normal
VERIFIED DUPLICATE of bug 7656
20 years ago
20 years ago

People

(Reporter: esther, Assigned: troy)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

20 years ago
problem: background color for table index watch on right side of page not
displaying.
Found while doing the "top sites" checking.  Using the latest seamonkey
builds available today 2/5.

Comment 1

20 years ago
per leger, assigning QA contacts to all open bugs without QA contacts according
to list at http://bugzilla.mozilla.org/describecomponents.cgi?product=Browser

Updated

20 years ago
QA Contact: 4110 → 4144
Target Milestone: M4

Comment 2

20 years ago
Updating QA Contact.  petersen...how does this look with latest apprunner?

Comment 3

20 years ago
Same problem as described. This happens with the March 10th AppRunner builds for
Mac, Windows, and Linux

Comment 4

20 years ago
not compositor related...

Updated

20 years ago
Assignee: michaelp → troy
Component: Compositor → Layout

Comment 5

20 years ago
Setting to Layout.
(Assignee)

Updated

20 years ago
Assignee: troy → karnaze

Updated

20 years ago
Status: NEW → ASSIGNED

Updated

20 years ago
Target Milestone: M4 → M5

Comment 6

20 years ago
moving to M5

Updated

20 years ago
Target Milestone: M5 → M6

Comment 7

20 years ago
Moving to M6

Comment 8

20 years ago
Moving to M8

Comment 9

20 years ago
Created attachment 266 [details]
test case; background GIF not repainted on scroll right

Comment 10

20 years ago
Test case is a simple page with <body background> and a <div> of width 700px.
Shows same bug.

Updated

20 years ago
Assignee: karnaze → kipp
Status: ASSIGNED → NEW

Comment 11

20 years ago
The test case involves an image on the body. Reassigning to Kipp.

Updated

20 years ago
Assignee: kipp → peterl

Comment 12

20 years ago
Background propogation bug. Taking this.

Comment 13

20 years ago
*** Bug 7558 has been marked as a duplicate of this bug. ***

Updated

20 years ago
Assignee: peterl → troy

Comment 14

20 years ago
Here's one of those background propogation issues we talked about. This is an
example of HTML background not stretching to fill the viewport.
(Assignee)

Updated

20 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 15

20 years ago
The problem is I think we're doing exactly what CSS2 says we should do

Per 10.3.3 we compute the HTML element's 'width' based on its containing block
width (the window width). That means the HTML element's box is only as wide as
the window. The content that overflows is 'visible', but the CSS spec says
background is only rendered over the content and padding areas of the box and
that means not in the overflow area.

What we used to do was to make the HTML element's width as wide as its
overflowed content. That meant the background color was displayed all the way
out.

That meant that we failed Ian's tests where he explicitly sets the 'width'
property and then checks that we do in fact use that value and do not extend the
width to include the overflowed content

Maybe there's a section (or should be a section) that distinguishes between an
explicit value for 'width' and 'auto', but I don't currently see such as section
CSS2 14.2 ( http://www.w3.org/TR/REC-CSS2/colors.html#q2 ) says:

The background of the box generated by the root element covers the entire
canvas.

I think Ian is working on updating some of his tests based on this statement.
(Assignee)

Updated

20 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 20 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 17

20 years ago
*** This bug has been marked as a duplicate of 7656 ***

Updated

20 years ago
Status: RESOLVED → VERIFIED

Comment 18

20 years ago
Agreed. This bug is a duplicate of 7656.
You need to log in before you can comment on or make changes to this bug.