<DIV style='overflow-y: scroll;'> without "overflow: auto;" causes text to over-run the div box.

RESOLVED WORKSFORME

Status

()

Core
XUL
RESOLVED WORKSFORME
13 years ago
12 years ago

People

(Reporter: luxuryoils, Assigned: jag (Peter Annema))

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

<DIV style='overflow-y: scroll;'> without "overflow: auto;" causes text to
over-run the div box.

<DIV style='overflow: scroll;'> (without the "-y" and "overflow: auto;")
functions correctly.

Reproducible: Always

Steps to Reproduce:
1. Load page.

Actual Results:  
Div box text over-runs the box and no Y scrollbar is displayed

Expected Results:  
Y only scrollbar to be displayed and text to stay within the div box.

I have a zip of a test case that fails on FF 1.0.4 but works with IE (it is of a
user-only site so the URL would be useless).  Also adding "overflow: auto;" to
the <DIV> statement does correct the problem.
(Reporter)

Comment 1

13 years ago
Created attachment 186282 [details]
Saved webpage "cache_details.aspx.html" displays the problem
overflow-y isn't supported in the 1.7.8 branches. In the nightly trunk builds,
it is supported.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 3

12 years ago
Created attachment 197290 [details]
Bug is still happening in 1.0.7

I used the previously attached zip'ed html to show the error.  It is still
happening in 1.0.7
Yes, because 1.0.7 is not a latest nightly trunk build.
You can try these builds out here:
http://ftp.scarlet.be/pub/mozilla.org/firefox/nightly/latest-trunk/
You need to log in before you can comment on or make changes to this bug.