If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

can't print java applets output under Linux

RESOLVED DUPLICATE of bug 178930

Status

Core Graveyard
Java: OJI
--
major
RESOLVED DUPLICATE of bug 178930
12 years ago
7 years ago

People

(Reporter: Priit Randla, Assigned: Kyle Yuan)

Tracking

1.7 Branch
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.7) Gecko/20050427 Fedora/1.7.7-1.3.1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.7) Gecko/20050427 Fedora/1.7.7-1.3.1

Java applets display ok on display and their output can be sent to printer under
Windows, using Firefox. Under Linux, applets are not printed - no errors, just a
blank area on the paper where applets output should be. Tried it using Sun JRE
1.4.2 and 1.5.0, mozilla 1.7.[5-7], Firefox 1.0.4.

Reproducible: Always

Steps to Reproduce:
1.go to the page with an java applet 
2.File->Print
3.

Actual Results:  
Instead of applet-generated content there is blank area on the paper. Other
components of the web-page print correctly.

Expected Results:  
Applet's output correctly sent to the paper.

Mozilla 1.7.7;1.7.6, Firefox 1.0.4 were tested and found buggy. 
Firefox 1.0.4 under Windows XP worked ok.
Assignee: general → yuanyi21
Component: General → Java: OJI
Product: Mozilla Application Suite → Core
QA Contact: general → oji
Version: unspecified → 1.7 Branch

Comment 1

12 years ago
Related to/duplicate of bug 41549, bug 178930 and Firefox bug 295369?
(Reporter)

Comment 2

12 years ago
(In reply to comment #1)
> Related to/duplicate of bug 41549, bug 178930 and Firefox bug 295369?

Yes, it seems so (at least 178930 and Firefox 295369 seem to apply).
So it can be marked as a duplcate. Shame on me for not being able to  find those
myselt...

Still, the problem remains and reading all those comments I still do not
understand what's wrong and is it somehow possible to improve the situation? 
Why does it work on Windows?
Both java and Mozilla should be multiplatform apps, shouldn't they? 
Just trying to understand.

Comment 3

12 years ago
see bug 178930 comment 4

*** This bug has been marked as a duplicate of 178930 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE

Updated

7 years ago
Component: Java: OJI → Java: OJI
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.