7-day week view does not resize to fit window

RESOLVED FIXED

Status

Calendar
Sunbird Only
RESOLVED FIXED
13 years ago
12 years ago

People

(Reporter: ethanwransom, Assigned: Mostafa Hosseini)

Tracking

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

When I switch to 7-day view in the 'Week view' pane with the current Calendar
extension (subscribed to a remote iCal file), the calendar does not resize, so I
lose half of Friday and Saturday. In Sunbird, a scroll bar appears, so I'm fine
there, but with Calendar, which I believe is intended to shrink the screen to
fit (which it does in 'Month' and 'Multiweek' view), there's no way to move over
to Friday and Saturday. I'm not sure why the week view won't resize, because the
events themselves are aligned to the original grid until reloading the calendar:
then they snap to the new weekday width.

Reproducible: Always

Steps to Reproduce:
1.Open Firefox 1.0.4 and install the current Calendar Extension.
2.Subscribe to a remote iCal calendar file.
3.Create a calendar with events on Mon through Friday.
4.Switch to week view, making sure that all 7 days are meant to show. Hopefully,
you're seeing Friday half gone and Saturday all gone.
5.Uncheck the remote calendar, and you'll see the window snap back to normal day
width.
6.Recheck the remote calendar, and you'll see the events appear aligned to the
narrow day grid, but the weekday grid suddenly widened for unknown reasons.
7.Reload the calendar, and you'll the events line up with the appropriate days,
but again, no scroll bar to be able to move over.

Actual Results:  
See the bug details

Expected Results:  
The weekday grid should have stayed the same width to line up with the remote
calendar's events, eliminating the need for a scroll bar, or a scroll bar should
appear.
(Reporter)

Comment 1

13 years ago
Another thing I think it might be: the all-day events in the remote iCalendar
File are not lined up with the narrow day-grid or wide day grid. Perhaps the
reason for this problem is the reason for the misalignment.

Comment 2

12 years ago
Scrollbars appear for me in the new-views.  Fixed by the switch to the new views (bug 297934)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.