[Mac & Linux] edit feed URL needs to appear as disabled

RESOLVED INVALID

Status

RESOLVED INVALID
13 years ago
7 years ago

People

(Reporter: bugzilla, Assigned: mscott)

Tracking

Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
I've noticed this with recent (at least since 20050614) trunk builds on Mac and
Linux: cannot seem to edit the feed URL.

1. make sure you already have some RSS feeds you've subscribed to.
2. open the RSS Subuscriptions dialog.
3. select and expand a feed folder, and select a feed.
4. click the Edit button (or double-click the feed).
5. in the resulting dialog, try to change the content in the Feed URL textfield.

results: unable to change the Feed URL textfield. problematic if the feed's URL
changes.
(Reporter)

Comment 1

13 years ago
hm, wonder if the fix for 289629 might've caused this?

this was a bug in a 2005050910-trunk build.
(Assignee)

Comment 2

13 years ago
This was done by design and I thought this was true back in 1.0 as well but
maybe it was something I did with the new UI.

Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 3

13 years ago
if this is by design, then we might as well make the content in the URL Feed
field appear disabled.
Keywords: regression
(Assignee)

Comment 4

13 years ago
sarah it is disabled, the textbox should have a big grey box in the back ground.
IT looks disbled on windows. :)
(Reporter)

Comment 5

13 years ago
(In reply to comment #4)
> sarah it is disabled, the textbox should have a big grey box in the back ground.
> IT looks disbled on windows.

it doesn't have the disabled appearance on the Mac --perhaps that's a theme
issue then?

Comment 6

13 years ago
I don't mean to be an idiot, but why can't you change where a feed is located?

In addition, would a 302 Permanent Redirect (not sure if its 302) change the URL
for you?
(Assignee)

Comment 7

13 years ago
your right sairuh, I see this on Mac OS X where the texbox doesn't look disabled.
Status: RESOLVED → REOPENED
OS: All → MacOS X
Hardware: All → Macintosh
Resolution: WONTFIX → ---
(Reporter)

Comment 8

13 years ago
it's also the case on Linux, too. (looking at yesterday's trunk build there.)
Summary: unable to edit feed URL → [Mac & Linux] edit feed URL needs to appear as disabled
Depends on: 338887
Depends on: 339395
Sorry for the dependency bugspam: two Core:Widget bugs and not the one Toolkit bug I thought. Should be fixed on Mac once I get a checkin.
Depends on: 339192
No longer depends on: 338887

Comment 10

12 years ago
Well, regarding the question whether this is by design.  There is an edit button in the UI interface and it pops up a dialog where one assumes to be able to edit the feed URL.  Alas, it is not possible.  It would be nice to change it, though.

Comment 11

12 years ago
*** Bug 354095 has been marked as a duplicate of this bug. ***

Comment 12

12 years ago
*** Bug 361207 has been marked as a duplicate of this bug. ***

Comment 13

12 years ago
I'm using Thunderbird 1.5.0.8 (20061025) on Windows with the default theme, and the Feed URL does not appear as being disabled. I wasn't aware that the field was intended to be read-only... it would be very nice if we could edit feed URLs.
QA Contact: rss

Comment 14

11 years ago
Not being able to edit the URL of the feed is really annoying. For instance, if your Bugzilla installation is restricted to logged in users only, you have to manually add the Bugzilla_login and Bugzilla_password to the URL so that you can still download feeds. But Thunderbird doesn't let us do it. Instead of disabling the URL field, I would prefer to see it editable for real.
OS: Mac OS X → All
Hardware: Macintosh → All
Fixed up the dependency chain - it now looks (roughly, fairly) disabled on Linux.

Let's start with a fresh bug for the "it shouldn't look or be disabled, I want to change it" thing.
Status: REOPENED → RESOLVED
Last Resolved: 13 years ago11 years ago
Resolution: --- → FIXED

Updated

10 years ago
Status: RESOLVED → VERIFIED

Updated

9 years ago
Component: RSS → Feed Reader
Product: Thunderbird → MailNews Core

Comment 16

7 years ago
Can you please reopen this? Build "Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.2.23) Gecko/20110922 Thunderbird/3.1.15" still has this problem.

Comment 17

7 years ago
I can't spot how this looks disabled, either.  Reopening.

Did anybody ever open the "it shouldn't look or be disabled, I want to change it" ticket?
Status: VERIFIED → REOPENED
Resolution: FIXED → ---

Comment 18

7 years ago
the feed url can now be updated in the Subscribe dialog, per bug 716706.
Status: REOPENED → RESOLVED
Last Resolved: 11 years ago7 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.