While compiling firefox 1.0.4 with GCC 4.0.0 build ends in error on oiddata.h

RESOLVED DUPLICATE of bug 284386

Status

()

Firefox
Build Config
RESOLVED DUPLICATE of bug 284386
13 years ago
13 years ago

People

(Reporter: Stef van der Made, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
During the compile process the following error occur when compiling firefix
1.0.4 using gcc 4.0.0, glibc-2.3.4, kernel 2.6.11-rc6 

gcc -o Linux2.6_x86_glibc_PTH_OPT.OBJ/asymmkey.o -c -O2 -fPIC -DLINUX1_2 -Di386
-D_XOPEN_SOURCE -DLINUX2_1 -ansi -Wall -pipe -DLINUX -Dlinux -D_POSIX_SOURCE
-D_BSD_SOURCE -DHAVE_STRERROR -DXP_UNIX -DNSS_3_4_CODE -UDEBUG -DNDEBUG
-D_REENTRANT
-I/usr/download/garnome-2.11-20050610.1755/bootstrap/firefox/work/main.d/mozilla/dist/include
 -I../../../../dist/public/nss -I../../../../dist/private/nss
-I../../../../dist/include
-I/usr/download/garnome-2.11-20050610.1755/bootstrap/firefox/work/main.d/mozilla/dist/include/nspr
-I/usr/download/garnome-2.11-20050610.1755/bootstrap/firefox/work/main.d/mozilla/dist/include/dbm
-I../../../../dist/public/nspr  asymmkey.c
In file included from ../../../../dist/private/nss/nsspki1.h:57,
                 from nsspki.h:56,
                 from asymmkey.c:39:
../../../../dist/private/nss/oiddata.h:46: error: array type has incomplete
element type
gmake[5]: *** [Linux2.6_x86_glibc_PTH_OPT.OBJ/asymmkey.o] Error 1

*** This bug has been marked as a duplicate of 284386 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.