replacing word from spell checker dialog doesn't update in compose window

VERIFIED DUPLICATE of bug 288161

Status

Thunderbird
Message Compose Window
VERIFIED DUPLICATE of bug 288161
13 years ago
13 years ago

People

(Reporter: sairuh (rarely reading bugmail), Assigned: Scott MacGregor)

Tracking

Trunk
PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
found using 2005061505-trunk tbird bits on Mac OS X 10.4.1. cannot seem to repro
on Linux with a recent trunk build. not a problem with inline spelling.

1. open a mail compose window (doesn't matter if it plaintext or HTML).
2. go to the compose region and enter a misspelled word, eg, "wott"
3. bring up the spell checker dialog (cmd+K or click the toolbar button).
4. select a correctly spelled replacement (eg, "watt"), click the Replace button
then the Close button.
5. look at the compose window.

results: the misspelled word still appears in the mail compose window.

note, however, that if I save the message the draft displays the corrected
spelling. in addition, sending the message will send the corrected spelling. but
unfortunately minimizing then restoring the window doesn't seem to repaint the
content correctly.

I'll see if this occurred in 1.1a1 (or 1.0.2), to see if it's a regression.

Marcia or Tracy, are you able to repro this on Windows or another OS X version,
eg, 10.3.x?

Comment 1

13 years ago
still reproducable on mac OS 10.3.9

dupe of bug 288161

*** This bug has been marked as a duplicate of 288161 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 2

13 years ago
d'oh!
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.