Can't go back to previous page if URL is the same except for case

RESOLVED DUPLICATE of bug 99091

Status

()

Firefox
Bookmarks & History
RESOLVED DUPLICATE of bug 99091
13 years ago
10 years ago

People

(Reporter: Brian Kell, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050513 Fedora/1.0.4-1.3.1 Firefox/1.0.4
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050513 Fedora/1.0.4-1.3.1 Firefox/1.0.4

If you follow a link on a page that points to a URL that is identical to the
current page except for case differences, it is impossible to use the back
button to return to the page you were on.

It seems that Firefox seems to treat such a link as a reload of the current page
instead of a different URL.

Remember, only the "http://server/" part of a URL is case-insensitive; the path
is allowed to be case-sensitive (and often is).

Reproducible: Always

Steps to Reproduce:
1. Go to http://en.wikipedia.org/wiki/Avi
2. Click on the link at the top ("For the file format, see AVI.") which goes to
http://en.wikipedia.org/wiki/AVI

Actual Results:  
If the "Avi" page was the first page loaded in a tab, the back button is
disabled. Otherwise, the back button will take you to the page before "Avi".

Expected Results:  
From "AVI", the back button should return you to "Avi".

*** This bug has been marked as a duplicate of 99091 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE

Updated

10 years ago
Component: History → Bookmarks & History
QA Contact: history → bookmarks
You need to log in before you can comment on or make changes to this bug.