Bookmark bar not retaining imported & copied entries from Bookmarks pane

RESOLVED FIXED

Status

RESOLVED FIXED
14 years ago
14 years ago

People

(Reporter: mark.yannuzzi, Assigned: sfraser_bugs)

Tracking

({fixed1.8})

Details

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en) AppleWebKit/412 (KHTML, like Gecko) Safari/412
Build Identifier: 

Camino v8.0 thru 8.4 and currently Version 2005061508 (0.9a1):
1) I import/"save to..." my  bookmarks from URL Manager Pro 3.x.
2) Open Camino.
3) Open Bookmarks Pane
4) Move/Copy my "Toolbar Favoraites" entries to "Bookmark bar.
5) They show up succesfully.
6) Quit Camino
7) Bookmark bar empty...Bookmarks menu O.K., save imported entries.

Problem does not occur for Firefox 1.0.x OR Safari OR Mozilla.
Been happening under Panther & Tiger since about Camino v8.x

Reproducible: Always

Steps to Reproduce:
1) I import/"save to..." my  bookmarks from URL Manager Pro 3.x.
2) Open Camino.
3) Open Bookmarks Pane
4) Move/Copy my "Toolbar Favoraites" entries to "Bookmark bar.
5) They show up succesfully.
6) Quit Camino
7) Bookmark bar empty...Bookmarks menu O.K., saves imported entries.

Actual Results:  
As described.

Expected Results:  
Save the state/entries of the Bookmark bar.
Mike and Simon checked in some fixes for disappearing bookmarks issues this
weekend...can you check an 8-1 or later nightly and see if the problems still
occurs?
(Reporter)

Comment 2

14 years ago
(In reply to comment #1)
> Mike and Simon checked in some fixes for disappearing bookmarks issues this
> weekend...can you check an 8-1 or later nightly and see if the problems still
> occurs?

On 8-2-05 I started with Camino v8.4 and then used CaminoKnight v2.5 to update to the latest nightly 
buid (latest log entry 7-31-2005) which in the Finder appears as v0.9a2+.  I am running Tiger 10.4.2.

I tried 2 different way to import my bookmarks into Camino:
  1) Used URL Manager Pro 3.4.2 to "Export bookmarks to...Camino".  Which succeeds.
  2) Launch Camino and open Bookmars window.
  3) Open imported "Toolbar Favorites" and drag or option-drag to "Bookmark Bar" Group.
  4) Bookmarks now appear in Camino's Bookmark Bar.
  5) Quit Camino.
  6) Launch Camino again.
  7) Items in Camino's Bookmar Bar are gone.

  8) Use Camino's "Import Bookmarks..." menu item to import from Safari.
  9)-14) Repeat 2)-7) replacing "Toolbar Favorites" with "BookmarksBar".

Results are the same...Items contained in Bookmark Bar are not retained launch-to-lauch.

What happens if you create a fresh profile (move your ~/Library/Application
Support/Camino folder aside) and then try the URLMP/Safari import, etc.?
(Assignee)

Comment 4

14 years ago
I think this is because the bookmarks code is lame, and uses indices of the
children of the root to decide which is the toolbar bookmarks folder. The
imports probably add more root folders.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 5

14 years ago
I just tried this, and could not reproduce the issue.

Reporter: could you attach your bookmarks.plist file from
~/Library/Application Support/Camino please?
(Reporter)

Comment 6

14 years ago
(In reply to comment #3)
> What happens if you create a fresh profile (move your ~/Library/Application
> Support/Camino folder aside) and then try the URLMP/Safari import, etc.?

1) IMPORT FROM SAFARI:
    O.K.  I deleted my ~/Library/Application Support/Camino folder, then started Camino v0.9a2+, used 
the File->Import Bookmarks...Safari.  I then option-dragged the items in the Imported Safari 
Bookmarks->BookmarksBar "folder" to the Camino->Bookmark Bar container.  The items show in 
Camino's Bookmark Bar.  I quit, then relaunch Camino and now they ARE THERE!! Hoorah!

2) EXPORT FROM URLMP IN HTML FILE, CAMINO->IMPORT BOOKMARKS FROM FILE...
    I again delete ~/Library/Application Support/Camino folder first.  I then exported my URLMP 
bookmarks file to an HTML file and used Camino's Import Bookmarks command to import this file.  I 
then copy/move the Toolbar Bookmarks to Camino's Bookmark Bar.  I quit & restart, and they ARE 
retained.

3)  USE URLMP's File->Save To Browser->Camino COMMAND.
     Deleted ~/Library/Application Support/Camino folder first.  Select File->Save To Browser->Camino 
in URLMP.  Answer Yes to overwrite? prompt.  Start Camino, copy/move the Toolbar Bookmarks to 
Camino's Bookmark Bar.  I quit & restart, and they ARE NOT retained.

So, this narrows it down a bit.  3) used to work with earlier (< 0.8.4) Camino builds.
(Reporter)

Comment 7

14 years ago
Here is the "broken" bookmarks.plist you requested...
(Assignee)

Comment 8

14 years ago
Thanks, will take a look.
Assignee: pinkerton → sfraser_bugs

Updated

14 years ago
Summary: Bookmark bar not retaing imported & copied entries from Bookmarks pane → Bookmark bar not retaining imported & copied entries from Bookmarks pane
(Assignee)

Comment 9

14 years ago
This is fixed now, as part of my bookmark cleanup checkin.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
(Assignee)

Updated

14 years ago
Keywords: fixed1.8
You need to log in before you can comment on or make changes to this bug.