Need facility to resend auto-perform commands upon reconnect

RESOLVED INVALID

Status

Other Applications
ChatZilla
RESOLVED INVALID
13 years ago
13 years ago

People

(Reporter: WG9s, Assigned: Robert Ginda)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [WFM])

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050613 Firefox/1.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050613 Firefox/1.0+

I have chatzilla configured via the auto perform facility to send a "msg
nickserv identify" command when I connect t, the command is not resent when it
reconnects.  There should be a way to specify that and auto perform command
should be resent upon reconnect.

Reproducible: Always

Comment 1

13 years ago
WFM. 0.9.67+
(*) How are you reconnecting? (using /reconnect or by being disconnected by the
server, and then connecting again yourself/autoreconnecting)
(*) What version of ChatZilla are you using?
(*) What server is this happening on? (I tested using irc.chatcircuit.com)

Comment 2

13 years ago
The autoperform commands are always run when connecting to a server, when it
sents the madatory 001 message:
 http://lxr.mozilla.org/mozilla/source/extensions/irc/xul/content/handlers.js#881

Damnit, where's the option to make the bug UNCONFIRMED? Stupid Bugzilla.

This bug has NOT been confirmed.
Whiteboard: [WFM]
(Reporter)

Comment 3

13 years ago
I will try to provide a few more details about the circumstances under whihc I
have oserved this problem the next time it happens.  This has happened if a
network error causes a disconnect and chatzilla is set to automatically
reconnect and rejoin channels.  I have had to manually enter the msg nickserv
IDENTIFY command even though it is in the auto perform list for the server I was
connected to.  This is occuring with chatzilla version 0.9.69.5 with a Firefox
trunk build from this week.

On the bugzilla front, I have noticed too that it is not possible for a person
who has canconfirm priviledge to submit an uncomfirmed bug.

Comment 4

13 years ago
After the reconnect, I would like you to check that doing "/network-pref
autoperform" shows your auto-perform identification.

Could you also tell us if this is a built-in network, one you added, or a single
server?
(Reporter)

Comment 5

13 years ago
Nevermind.  I just tested.  It does send the identify command to nickserv it
just does not work because it managed to reconnect before the server end timed
out.  Since my nick with the underscore is not registered, the identify command
does not work.

-> INVALID
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.